Q100301: "An unexpected error occurred" when trying to install a license

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SYMPTOMS

When installing or activating your license on a machine, you may encounter the following errors:

An unexpected error occurred

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CAUSE

There is a known issue with licensing where our programs are unable to write a license file or create the directory if the file path contains non-ASCII characters. This can happen if your username contains special characters such as an accented letter (e.g. ë) or an @ symbol.

 

This error can also occur if the system date and time of your machine is set in the future or you have future modified dated files on your machine.  Further information on this issue can found in this guide:  Q100217: How to resolve the "Clock setback detected" error message

 

RESOLUTION

You can workaround this issue in a number of ways:

All license types:

Changing the username to remove the non-ASCII character(s) should resolve the issue for all license types.

Login-based licensing:
For login-based licenses, including non-commercial, you can tell our programs to use a different directory to store the license by setting the FN_SUBSCRIPTION_LICENSE_DIR environment variable.

For example, to store the files in C:\Licenses you would set

FN_SUBSCRIPTION_LICENSE_DIR = C:\Licenses

Please see Q100015: How To Set Environment Variables for information on how to set an environment variable.

Node-locked licenses:

When installing a node-locked license using the FLU 8.1.6, it will write the license to your user area. You can use FLU 8.1.3 to install the license to your system location instead in order to avoid this issue.

The FLU 8.1.3 can be downloaded via the following link:

Mac download

Linux (.deb) download

Linux (.rpm) download

Windows download

Once FLU 8.1.3 has been installed please follow the steps in the following article to install the license: Q100026: How to install a node-locked license 

 

The FLU 8.1.3 installs licenses to the path below. Manually dragging the .lic file to this location should also fix the issue:

Windows: C:\ProgramData\The Foundry\RLM\ and C:\Program Files\The Foundry\RLM\

macOS: /Library/Application Support/TheFoundry/RLM/

Linux: /usr/local/foundry/RLM/


FURTHER READING

More information about licensing is available in the following articles:

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