Q100217: How to resolve the "License not yet valid, may be valid in the future" error message

Follow

SYMPTOMS

When installing a nodelocked or floating license, activating a login-based license or when running a program you might encounter the following error message:
 
"License not yet valid, may be valid in the future"

This error will prevent you from installing the license and/or prevent the program from running.

CAUSE

This error message can happen if the system time of your computer has been changed by a large amount.  

To prevent temporary licenses being used past their expiration date, the licensing code in our software looks to see if the system time has been been changed too much by checking the last-modified timestamp values of system files and directories.

Whilst this does prevent a user from winding back their computer clock to keep using an expired demo license it can trip up users who have previously changed their system date for testing purposes.

 

RESOLUTION

The first step to fixing this issue is to make sure your computer has the correct setting for local date and time. If possible, use the operating systems settings to automatically get the date and time from the internet.  After you correct the date/time setting, applying any pending OS updates and/or rebooting the machine may be enough to fix the issue.
 
If that doesn't fix the issue then you'll need to search your computer to locate any files or directories with last modified timestamp ahead of today's date and update them to change the last modified timestamp to the current time.  Once you've fixed all the problematic files and directories you should then be able to install your license and run the program.
 
If you are experiencing this issue with a full commercial license and are unable to resolve it then please use the Create a Ticket link above to contact the Support team.  NOTE: The Create a Ticket link will only appear when you are logged in to our website.  Please include the following information on the support ticket:
  • Screenshot of the error message
  • A copy of the license you're trying to install or the email address associated with a login-based license
  • A diagnostic output file from the Foundry License Utility (FLU) from the affected machine.  Instructions on how to generate this are in Q100105: Diagnosing License Problems
 
Was this article helpful?
0 out of 0 found this helpful