症状
如果您在启动Foundry服务器时遇到问题,可能会在诊断日志中看到以下错误消息:
02/17 11:27 (rlm) foundry :0 initialization error: 8, not restarting
02/17 11:27 (rlm) foundry - lockfile problems
02/17 11:27 (rlm) This usually means another "foundry" server is running
原因
当Foundry ISV 服务器启动时,它会将服务器锁定文件写入 Reprise 目录。创建此锁定文件是为了记录 RLM 服务器正在为Foundry (或任何其他 ISV 供应商守护程序)运行。
错误信息“初始化错误:8,未重启”“Foundry 锁定文件问题”表明服务器在创建此目录中的Foundry锁定文件时遇到问题。如果同一台服务器上同时运行着另一个foundry ISV 服务器,则通常会出现这种情况。
如果 ISV 服务器没有正常退出,并且Foundry服务器的另一个实例仍在服务器机器上运行,则可能会发生这种情况。
解决
如果您在许可证服务器上遇到此问题,最好的办法是卸载服务器上的所有Foundry RLM 服务器,然后重新安装最新的服务器工具。
要通过 FLU 8 及更高版本卸载服务器工具,请执行以下步骤:
- 启动Foundry许可实用程序应用程序
- 选择许可证服务器>卸载
- 按照屏幕上的说明卸载服务器工具。
如果您安装了任何来自 FLU 7 的旧版服务器工具,请参考以下文章卸载这些工具: Q100135:如何卸载旧版本的Foundry许可工具
当所有服务器工具都从许可证服务器卸载后,请按照本文中的步骤重新安装最新的服务器工具: Q100360:如何安装浮动/服务器许可证的服务器工具
安装完成后请务必重启服务器。这样可以使许可证再次生效。
更多帮助
如果您仍然遇到困难,请创建支持工单,告知我们遇到的具体问题以及已采取的故障排除步骤。
如需了解如何提交支持请求,请参阅本文:
延伸阅读
我们的支持门户网站提供有关使用浮动许可证的更多信息和建议。以下是与此问题相关的具体指南:
我们很遗憾听到
请告诉我们