Q100643: "foundry-lockfile problems" 오류로 인해 RLM 서버를 시작할 수 없습니다.

증상

Foundry 서버를 시작하는 데 문제가 있는 경우 진단 로그에 다음과 같은 오류 메시지가 표시될 수 있습니다.

02/17 11:27 (rlm) foundry :0 initialization error: 8, not restarting

02/17 11:27 (rlm) foundry - lockfile problems

02/17 11:27 (rlm) This usually means another "foundry" server is running

원인

Foundry ISV 서버가 시작되면 서버 잠금 파일이 Reprise 디렉터리에 기록됩니다. 이 잠금 파일은 Foundry (또는 다른 ISV 공급업체 데몬)를 위해 RLM 서버가 실행 중임을 나타내는 참조/레코드로 생성됩니다.

"초기화 오류: 8, 재시작 불가", "파운드리 잠금 파일 문제" 오류 메시지는 서버가 이 디렉터리에 Foundry 잠금 파일을 생성하는 데 문제가 있음을 나타냅니다. 이는 일반적으로 다른 foundry ISV 서버가 동일한 서버 머신에서 동시에 실행 중인 경우에 발생합니다.

ISV 서버가 정상적으로 종료되지 않고 Foundry 서버의 다른 인스턴스가 서버 머신에서 계속 실행 중인 경우 이런 문제가 발생할 수 있습니다.

해결

라이선스 서버에서 이 문제가 발생하는 경우 가장 좋은 대처 방법은 서버 컴퓨터에서 발견된 모든 Foundry RLM 서버를 제거하고 최신 서버 도구를 다시 설치하는 것입니다.

FLU 8 이상을 통해 서버 도구를 제거하려면 다음 단계를 실행하세요.

  1. Foundry Licensing Utility 애플리케이션을 실행합니다.
  2. 라이선스 서버 선택 > 제거
  3. 화면의 지시에 따라 서버 도구를 제거하세요.

FLU 7에서 설치된 이전 서버 도구가 있는 경우 다음 문서를 사용하여 이러한 도구를 제거하세요. Q100135: Foundry Licensing Tools의 이전 버전을 제거하는 방법

라이선스 서버에서 모든 서버 도구가 제거되면 이 문서의 단계에 따라 최신 서버 도구를 다시 설치하세요. Q100360: 플로팅/서버 라이선스용 서버 도구를 설치하는 방법  

설치 후 서버를 다시 시작하세요. 그러면 라이선스가 다시 플로팅됩니다.

추가 도움말

여전히 어려움을 겪고 있다면 지원 티켓을 생성하여 발생한 정확한 문제와 취한 문제 해결 단계를 알려주시기 바랍니다.

지원 요청을 여는 방법에 대한 자세한 내용은 다음 문서를 참조하세요.

Q100064: 지원 티켓을 제출하는 방법

추가 읽기

저희 지원 포털에서는 플로팅 라이선스 사용에 대한 자세한 정보와 조언을 제공합니다. 이 문제와 관련된 구체적인 가이드는 아래에서 확인하실 수 있습니다.

    우리는 문제로 불편을 끼쳐 드려 죄송합니다

    이유를 알려주세요