症状
Foundryサーバーの起動に問題がある場合は、診断ログに次のエラー メッセージが表示されることがあります。
02/17 11:27 (rlm) foundry :0 initialization error: 8, not restarting
02/17 11:27 (rlm) foundry - lockfile problems
02/17 11:27 (rlm) This usually means another "foundry" server is running
原因
Foundry ISVサーバーが起動すると、Repriseディレクトリにサーバーロックファイルが書き込まれます。このロックファイルは、 Foundry (またはその他のISVベンダーデーモン)用のRLMサーバーが実行中であることを示す参照/記録として作成されます。
「初期化エラー: 8、再起動しません」「Foundry ロックファイルの問題」というエラーメッセージは、サーバーがこのディレクトリにFoundryロックファイルを作成できない問題が発生していることを示しています。これは通常、同じサーバーマシン上で別のfoundry ISV サーバーが同時に実行されている場合に発生します。
これは、ISV サーバーが正常に終了せず、 Foundryサーバーの別のインスタンスがサーバー マシン上でまだ実行されている場合に発生する可能性があります。
解決
ライセンス サーバーでこの問題が発生した場合、最善の対処法は、サーバー マシンにあるすべてのFoundry RLM サーバーをアンインストールし、最新のサーバー ツールを再インストールすることです。
FLU 8 以降を使用してサーバー ツールをアンインストールするには、次の手順を実行してください。
- Foundryライセンスユーティリティアプリケーションを起動します
- ライセンスサーバー>アンインストールを選択
- 画面の指示に従ってサーバーツールをアンインストールします
FLU 7から古いサーバーツールがインストールされている場合は、次の記事を参照してこれらのツールをアンインストールしてください: Q100135: Foundryライセンスツールの古いバージョンをアンインストールする方法
ライセンスサーバーからすべてのサーバーツールがアンインストールされたら、この記事の手順に従って最新のサーバーツールを再インストールしてください: Q100360: フローティング/サーバーライセンス用のサーバーツールのインストール方法
インストール後は必ずサーバーを再起動してください。これにより、ライセンスが再びフローティング状態になります。
さらなる支援
引き続き問題が発生する場合は、サポート チケットを作成して、発生した問題の正確な内容と実行したトラブルシューティング手順をお知らせください。
サポート リクエストを開く方法の詳細については、次の記事を参照してください。
さらに詳しく
フローティングライセンスのご利用に関する詳細情報とアドバイスは、サポートポータルでご覧いただけます。この問題に関する具体的なガイドは以下をご覧ください。
私たちはそれを聞いて申し訳ございません
理由をお聞かせください