Q100083: How to fix "Failed to Install - Disk Write Permission Error" when installing your license

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SYMPTOMS

Disk permission problems can happen on Mac OS X, Windows and Linux and prevent the user from being able to install a license.

When attempting to install a license with the Foundry Licensing Utility (FLU) 8.0, if it cannot write the license to disk it will show an Invalid License error message with "Failed to Install - Disk Write Permission Error" as the reason.

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If you have tried to install the license from the Licensing dialog in an application it gives the error message "Status [Error]: Unable to open file."

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CAUSE

The license directory for node-locked, floating/server and client license files and the default installation path for floating licenses is a system location on the machine so that any user logged in to the machine can access a license.

  • Windows: "C:\ProgramData\The Foundry\RLM\" and "C:\Program Files\The Foundry\RLM\"
  • MacOS: /Library/Application Support/TheFoundry/RLM/
  • Linux: /usr/local/foundry/RLM/

Due to the directory being in a system location, creating the RLM directory and/or writing a license file to the location can require admin permissions. If the user running the FLU or application doesn't have admin permissions they may not be able to install a license.

 

RESOLUTION

If you are installing node-locked or client licenses, please install via FoundryLicensingUtility 8.1.6. The FLU can be downloaded via the following link: https://www.foundry.com/licensing/tools.

 

This installs the license to the user location which should not require any permissions. FLU 8.1.6 installs the license to the following path:

  • Windows: C:\Users\<username>\FoundryLicensing\
  • MacOS: /Users/<username>/FoundryLicensing/
  • Linux: /home/<username>/FoundryLicensing/

This path can only be used for node-locked and client license files, if you are installing a floating license, please try running the application or the Foundry Licensing Utility (FLU) as administrator before installing the license. Instructions on launching as an administrator are below:

Launching an application as Administrator

  • macOS: 
    Open a Terminal from Applications > Utilities and launch the program with sudo e.g.:

    sudo /Applications/Nuke15.1v1/Nuke15.1v1.app/Contents/MacOS/Nuke15.1
  • Linux:
    Launch the application from a terminal with sudo e.g.

    sudo /usr/local/Nuke15.1v1/Nuke15.1
  • Windows:
    Right-click on the shortcut for the application and select "Run As Administrator"

More info on launching the applications can be found at learn.foundry.com

 

Using the FLU in Administrator mode

  • macOS: 
    Open a Terminal from Applications > Utilities and run the following commands:

    cd /Applications/FoundryLicensingUtility.app/Contents/MacOS/
    sudo ./FoundryLicensingUtility
  • Linux:
    Run the following commands in a Terminal

    cd /opt/FoundryLicensingUtility
    sudo ./FoundryLicensingUtility
  • Windows:
    Right-click on the Foundry Licensing Utility (FLU) and click "Run as Administrator"

Then install the license as normal:

 

Windows - check file viewing permissions

If you still encounter problems on Windows then the next step is to check that your user can view the ProgramData folder so you can read and write license files.

In Windows Explorer, turn on 'Show Hidden Files and Folders' in the Windows Folders and Properties - View options.

 

FURTHER READING

For more information about licensing please see the Foundry Licensing Online Help

The Support Portal has articles on installing different license types and error message:

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