Q100531:如何解决通过 FLU 启动服务器时出现的“服务器许可证主机名不匹配”问题

症状

如果浮动/服务器许可证文件包含无效的主机名或 IP 地址,或者服务器机器无法解析或联系其自身的主机名,则许可证服务器将无法启动并在网络上浮动许可证。

如果发生这种情况, Foundry Licensing Utility (FLU) 8.0 及更高版本将许可证服务器页面上显示错误消息“服务器许可证主机名不匹配”:

mceclip0.png

以下警告消息将显示在 RLM 服务器日志中

06/19 11:50 (foundry) WARNING: No license file for this host (serverName)
06/19 11:50 (foundry)          The hostname in the license file(s)
06/19 11:50 (foundry)          may be incorrect

原因

这个问题主要有两个原因——许可证文件中的主机名不正确以及机器的主机名存在问题。

许可证文件中的主机名不正确

浮动许可证的第一行(即 HOST 行)包含有关将要浮动许可证的服务器机器的信息,格式如下:

HOST <server_name> <System_ID> <port number>
  • <server_name> 可以是服务器的本地主机名、完全限定域名 (FQDN) 或 IP 地址。
  • <System_ID> 是生成许可证所依据的系统 ID。它必须是机器的有效 MAC 地址,且不可编辑,否则许可证将无效。
  • <端口号> 是主 RLM 服务器进程运行的端口。为了避免与其他 RLM 服务器冲突, Foundry许可证在主机行中设置的端口为 4101。

Foundry Licensing Utility (FLU) 安装浮动许可证时,`<server_name>` 文本将被替换为机器的主机名。已安装许可证的主机行将如下所示:

HOST redserver1 001122334455 4101

如果已安装许可证中的主机名不正确,则 RLM 服务器将无法运行。这主要有两个原因:

  • 如果手动安装许可证,并且 <server_name> 字段未更新为服务器主机名或 IP 地址,则会出现问题。
  • 如果计算机在不同网络之间移动,并且安装许可证时使用的主机名在当前网络上无效,则会发生这种情况。

主机名问题

服务器要运行,机器需要能够使用许可证文件中指定的主机名与自身通信。如果文件中的主机名正确,但机器无法使用该主机名与自身通信,或者机器找不到主机名,则 RLM 服务器将无法启动。

如果您的计算机或网络存在 DNS 问题,则可能会出现这种情况。当使用 macOS 计算机作为许可证服务器且所有共享设置均已关闭时,这可能是一个常见问题。

解决

macOS 主机名以 .local 开头

在 macOS 系统中,如果主机名以 .local 结尾且共享设置已关闭,则可能会出现此问题。通常可以通过在服务器端的“系统偏好设置”中启用任何“共享服务”来解决此问题。

  1. 打开系统偏好设置
  2. 点击“共享” ,然后勾选“文件共享”复选框。
  3. 再次启动FLU,然后转到“许可证服务器” > “控制服务器”。现在您应该可以重启服务器了。

一般指导原则

要解决此问题,您需要检查许可证是否具有有效的主机名,以及机器是否可以与自身通信。

步骤 1. 检查服务器主机的主机名

您可以通过在终端或命令提示符中运行“hostname”命令来查找当前主机名。请记下主机名。

步骤 2. 检查许可证文件中的主机名

您可以通过点击“许可证” > “查看已安装”从 FLU 查看许可证中使用的主机名。主机名有效的许可证会显示在“有效许可证”部分,主机名无效的许可证会显示在“无效许可证”部分。

mceclip3.png

点击许可证将显示该许可证、其在计算机上的位置以及其无效的原因,在本例中为“主机和/或供应商规范无效”。

mceclip4.png

步骤 3. 如有需要,更新许可证文件

如果文件中的主机名与机器的主机名或 IP 地址不同,则需要先更新该文件,服务器才能运行。

  1. 单击“许可证安装位置”字段,打开许可证目录中的文件浏览器窗口。

  2. 使用文本编辑器编辑许可证文件,并将主机行更新为正确的主机名。

    注意:如果许可证的主机行中仍然包含 <server_name>,您可以将该文件移动到其他目录,然后使用 FLU 进行安装。方法是:单击“许可证”> “安装” ,然后选择该文件并单击“安装”。

  3. 再次转到“许可证” > “查看已安装” ,然后单击刷新按钮。FLU 将再次检查许可证是否有效。

如果许可证有效,您可以尝试启动服务器。点击“许可证服务器” > “控制服务器” ,然后点击出现的“启动”“重启”按钮。如果仍然出现错误消息,则说明计算机的主机名或 DNS 存在问题。

步骤 4. 检查并修复主机名问题

通过在机器上打开命令提示符或终端并运行以下命令,检查机器是否可以解析自身的主机名。

ping serverName

其中 serverName 是您在步骤 1 中得到的机器的主机名。您可以使用 Ctrl+C 取消 ping 操作。

如果 ping 命令报告 100% 丢包率或无法解析主机名,则表示存在主机名或 DNS 问题,导致许可证服务器无法启动。您可能需要联系系统管理员解决此问题。

后续步骤

如果无法解决机器和网络上的主机名或 DNS 问题,请联系您的系统管理员。

如果以上方法无法解决问题,或者服务器无法启动,请提交支持工单并包含以下信息:

延伸阅读

有关许可的更多信息,请参阅Foundry许可在线帮助许可证服务器管理部分。

支持门户网站提供了有关如何设置许可证服务器以及如何在您的计算机上查看许可证的信息,以下文章对此进行了说明:

    我们很遗憾听到

    请告诉我们