症状
当尝试使用基于个人登录的许可证启动以前版本的Nuke时,您可能会在许可对话框中看到“许可证到期警告”消息:
一旦到期, Nuke将无法再检出基于个人登录的许可证,并且将无法启动。
原因
我们的许可系统需要进行服务器端更改,这影响了我们的产品与服务器之间的通信,从而影响了早期产品版本。
因此,尽管有有效的许可证可用,但当本地许可证令牌尝试续订(每 37 天一次)时,个人许可证签出开始失败。
此问题影响所有操作系统上的基于登录的许可证,且仅限于 2025 年 5 月 20 日之前发布的Nuke版本。最新版本的Nuke不会受到此问题的影响。所有其他Foundry产品和许可证类型均未受到影响。
解决
最新版本的Nuke不存在此问题。如果您可以升级,我们建议您下载并安装以下Nuke系列产品版本之一:
- 16.0v3 及以上版本
- 15.2v3 及以上版本
- 15.1v8 及以上版本
- 15.0v8 及以上版本
- 14.1v8 及以上版本
您可以点击此处下载最新版本的Nuke系列产品: https: nuke
变通方法
如果您目前无法升级到Nuke系列产品的最新版本,您可以通过以下两种方法之一来解决此问题。
定期手动续订许可证令牌
要解决此问题,您需要从个人登录许可系统中注销,从您的计算机中删除 Tokens 文件夹,然后重新登录。
注意:您的本地许可证令牌每 37 天续期时,您需要重复此操作。
有关如何执行此操作的分步指南,请参见此处: Q100285:帮助解决基于个人登录的许可问题的初始步骤
注意:您看到的警告是您计算机上特定许可证令牌的到期日期。这并不代表您的整体许可证权益已到期。
使用环境变量指向较新的Nuke证书包文件
您可以设置FN_CURLOPT_CAINFO环境变量,使其指向较新的Nuke证书包文件,这样就可以避免上述定期手动续订许可证令牌的步骤。
注意:在设置此环境变量之前,您需要删除所有现有的许可令牌。
要实现这一点,请按照本文中的指导进行操作: Q100720:如何在不升级到最新Nuke版本的情况下解决基于登录的许可问题
更多帮助
如果您按照本文所述步骤操作后仍然遇到任何问题,请提交支持工单,并告知我们您遇到的问题以及您目前已采取的故障排除步骤,包括任何错误消息的屏幕截图。
有关如何提交支持工单的更多信息,请参阅Q100064:如何提交支持工单文章。
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