Q100235:如何解决“与许可证服务器通信错误”许可错误消息

症状

设置好浮动许可证服务器并将计算机指向该许可证服务器后,程序无法运行并显示以下错误消息之一:

与许可证服务器通信错误(-17)

服务器拒绝连接(-111)
或者
与许可证服务器通信错误(-17)
网络读取错误(-105)

原因

如果服务器未运行,或者许可证服务器和客户端计算机(请求许可证的计算机)之间存在防火墙,则会显示此错误消息。

防火墙可能会阻止许可证请求,其方式可能是关闭许可证请求使用的端口,或者只允许服务器上已批准的程序与其他计算机通信。

我们也曾遇到过这样的错误:客户的网络安全系统将 RLM 流量识别为可疑流量并阻止了该通信。

解决

您可以通过更改防火墙设置来解决此问题,允许许可证服务器和许可证请求通过防火墙。这可以通过为服务器打开指定的端口,或者允许Foundry Licensing Tools (FLT) 中的 RLM 服务器程序通过服务器进行通信来实现。

有关如何设置的更多信息,请参阅Q100216:如何通过防火墙使用许可证服务器

如果您的网络安全级别很高,我们建议您为 ISV 设置一个专用端口,并允许该端口通过防火墙。有关如何操作的更多信息,请参阅以下文章: Q100374:如何使 RLM 服务器使用专用的 ISV 端口

更多帮助

如果您仍然遇到问题,请创建支持工单,详细说明遇到的问题以及已采取的故障排除步骤。请同时附上服务器和客户端机器的Foundry License Utility (FLU) 的所有诊断输出文件。

如需了解如何提交支持请求,请参阅以下文章: Q100064:如何提交支持工单

有关如何生成许可证诊断日志的更多信息,请参阅以下文章: Q100105:如何通过 FLU 生成许可证诊断日志以排查许可证问题

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