Q100677:尝试启动服务器时出现“端口 4101 仍在被使用,放弃”错误

症状

尝试启动 RLM 服务器时,服务器没有正常启动,许可证也没有正常浮动,而是出现以下错误:

 ==> 05/25 16:20 (rlm) Port 4101 in use, waiting...

==> 05/25 16:20 (rlm) Port 4101 in use, waiting...

==> 05/25 16:20 (rlm) Port 4101 in use, waiting...

==> 05/25 16:20 (rlm) Port 4101 still in use, giving up.
==> Error connecting to "rlm" server

==> Connection attempted to host: "<hostname>" on port 4101

==> Connection refused at server (-111)

==> Cannot connect to server (comm: -4)

原因

4101 是许可证文件 HOST 行中指定的端口,客户端计算机使用此端口请求许可证。默认情况下,我们颁发的Foundry许可证在 HOST 行中指定端口为 4101,以避免与其他 RLM 服务器冲突。

如果您看到端口正在使用的错误,这通常意味着此机器上还有另一个 RLM 进程正在使用端口 4101。

出现这种情况的原因之一是服务器上运行的最后一个Foundry RLM 会话没有正常退出。

解决
首先要确保的是,该服务器上没有其他供应商正在使用 4101 端口。

确认没有其他程序正在使用该端口后,请确保机器上所有旧的Foundry RLM 进程都已停止运行。您可以按照以下步骤彻底停止服务器运行:

  1. 启动Foundry许可实用程序 (FLU)
  2. 导航至“许可证服务器”和“控制”选项卡
  3. 如果可以,请停止服务器。
  4. 导航至“许可证服务器”和“卸载”选项,然后运行卸载程序。
  5. 请按照以下步骤重新安装服务器: Q100360:如何安装浮动/服务器许可证的服务器工具
  6. 启动服务器

如果您在无头机器上使用 FLU,请参阅此处停止和启动服务器的步骤。

如果您未使用 FLU,则可以通过 rlmutil 按照以下步骤停止服务器:

  1. 打开命令提示符或终端
  2. 使用以下命令导航到 rlmutil

    Windows: cd C:\Program Files\The Foundry \LicensingTools8.0\bin\RLM
    Mac: cd /Applications/TheFoundry/LicensingTools8.0/bin/RLM/
    Linux: cd /usr/local/ foundry /LicensingTools8.0/bin/RLM

  3. 使用 rlmdown 命令停止服务器:
    例如: rlmutil rlmdown foundry -c 4101@<hostname>

更多信息请参见此处:Q100659:什么是 rlmutil 以及如何使用它?

延伸阅读

如果您仍然遇到困难,请创建支持工单,告知我们遇到的具体问题以及已采取的故障排除步骤。

如需了解如何提交支持请求,请参阅本文:

Q100064:如何提交支持工单

有关 rlmutil 及其命令的更多信息,请参阅以下文档: Q100659:什么是 rlmutil 以及如何使用它?

有关如何管理许可证服务器的更多信息,请参阅这篇文章。

    我们很遗憾听到

    请告诉我们