Q100278:如果视图变为空或几何图形消失该怎么办?

症状

在某些情况下,用户可能会发现视图似乎已损坏或为空,并且似乎对导航或显示几何体没有响应。本文介绍了检查视图是否仍然处于活动状态、如何重新控制视口摄像机以及确保几何体可见的最佳方法。

这种现象通常出现在大型归档文件或在工作站之间传递过的归档文件中。在这种情况下,正交视图几乎看起来像是一个空白标签页,如下图所示,而其他视图(主要是 UV 视图)通常仍然显示资源可见:

EmptyViewport.png

原因

Mari这样复杂的软件,其视图出现异常的原因有很多,例如素材的可见性、裁剪平面,或者摄像机远离素材等。用户可能无意中触发某些行为,导致视图显示为空或无响应,例如误用快捷键。此外,还需注意可能存在的软件错误。

最好的方法是检查影响视图的每一个流程,并确保它们都设置正确。

解决

确认视图仍然有效

第一步是检查您的视图是否仍然包含Mari画布。为此:

  1. 通过选择“视图”>“调色板”>“灯光”来打开“灯光”调色板。
  2. 打开环境光灯。
  3. 在此调色板中,选择“环境”>“纹理”>“图像” ,然后选择一张 HDRI 图像,以便在环境光中使用它。
  4. 在同一菜单中,确保背景设置为显示

默认情况下, “环境光”选项处于关闭状态,因此很难判断Mari画布是否存在以及是否响应导航快捷键。但是,您可以看到,启用此选项后,更容易判断画布是否存在并且可以旋转。

以下是演示该过程的屏幕录像:

1启用环境.gif

重置油漆缓冲区比例

如果此时视口仍有响应,则很可能是因为您在绘制缓冲区中缩放过度而意外丢失了几何体。这种情况经常发生在处理高分辨率项目时,因此,如果您丢失了几何体,请务必尝试重置绘制缓冲区缩放比例。

为此,请从“工具”工具栏的“绘制缓冲区工具”组中选择“缩放绘制缓冲区”放大镜工具,然后在“工具属性”工具栏中选择“重置”按钮,如本屏幕录像所示:

3ResetPaintBuffer.gif

构图和调整相机

移动摄像机时,也有可能失去对目标的视线。

要将视图重新聚焦到您的资产上,请选择“相机”>“查看全部”

如果资源仍然不可见,则应尝试“相机”>“重置相机” 。这将重置画布工具栏中“近”“远”和“视场角”设置,这可能会对视图产生意外影响。例如,如果“近裁剪平面”设置过高,用户可能会使场景不可见。

图1_ResetCamera.png

调整相机的裁剪距离

在某些情况下,您可能会发现相机的默认裁剪距离会导致场景不可见。在正交视图中,相机的裁剪距离无法更改,因此如果您在透视视图中看不到场景,此故障排除步骤将非常有用。

透视视图相机的裁剪距离调整在Mari用户界面顶部的画布工具栏中进行。如果需要启用画布工具栏,可以右键单击现有工具栏。这将打开一个包含所有调色板和工具栏的菜单。请确保画布工具栏已启用。

启用 Canvas 工具栏后,您将看到名为“近”“远”的两个输入字段,以及FoV (视野)。


如果您的场景规模特别小,可以尝试将“近”值调小(例如 0.001);如果您的场景规模特别大,可以尝试将“远”值调大(例如 100,000.000)。

如果需要重置裁剪距离,请选择“相机”>“重置相机” 。这将重置画布工具栏中“近”“远”“视场角”设置。

解锁相机

导航工具栏可用于以各种方式限制摄像机的移动,直至完全锁定。编辑导航工具后,其图标会变为橙色,用户可能无法通过导航找到所需素材。

要完全解锁相机,用户必须按下最左边的按钮,该按钮称为“将导航设置重置为默认值”

资产可见性

Mari有三种“可见性模式”,具体取决于当前的“选择模式”。如果使用不当,用户可能会误以为无法显示他们的资产。

例如,如果用户在“面模式”下选中整个对象,然后选择“隐藏所选对象”将其隐藏,则无法通过“对象”面板显示该对象。这是因为该对象实际上仍然可见,只是其各个面不可见。

要使所有面、块和对象可见,而不管当前选择模式如何,用户必须使用“选择”>“全部显示”

添加新对象以重置视图

一些用户报告说,当上述所有故障排除选项都对他们无效时,他们可以通过向场景中添加一个大型 3D 模型来强制视图完全重新加载。

要向场景中添加新对象,用户可以选择“对象”面板,然后单击“添加对象”按钮:

添加的 3D 模型在每个轴上都应该大于 30 厘米,这相当于示例项目大小的两倍左右。可以通过选择“帮助”>“创建示例项目”来创建示例项目以供参考。

导航偏好

如果导航行为异常,用户还可以选择“编辑”>“首选项”>“导航” ,在那里可以将所有导航设置重置为默认值,或者更改控件类型,这会产生其他效果,例如更改与导航相关的快捷键。

着色器问题

也可能是渲染视图的着色器突然找不到资源,导致资源在渲染中消失。如果以上建议未能解决您的问题,请尝试选择“工具”>“着色器控制台”>“全部/重新加载着色器” 。这两个按钮都会重新加载着色器,这或许能帮助着色器再次找到并显示资源。

更多帮助

如果您遇到任何问题,请创建支持工单并向我们提供本文中要求的信息:
Q100090:报告Mari问题时需要发送给支持团队的信息

如需了解如何提交支持工单,请参阅本文:
Q100064:如何提交支持工单

    我们很遗憾听到

    请告诉我们