증상
플로팅 라이선스 서버를 설정하고 컴퓨터를 라이선스 서버로 연결한 후 프로그램이 실행되지 않고 다음 오류 메시지 중 하나가 표시됩니다.
라이센스 서버와의 통신 오류(-17)
서버에서 연결이 거부되었습니다(-111)
또는
라이센스 서버와의 통신 오류(-17)
네트워크에서 읽기 오류(-105)
원인
이 오류 메시지는 서버가 실행 중이 아니거나 라이선스 서버와 클라이언트 컴퓨터(라이선스를 요청하는 컴퓨터) 사이에 방화벽이 있는 경우 나타납니다.
방화벽은 라이선스 요청이 사용하는 포트를 닫거나 서버에서 승인된 프로그램만 다른 컴퓨터와 통신하도록 허용하여 라이선스 요청을 차단할 수 있습니다.
고객 네트워크 보안이 RLM 트래픽을 의심스러운 것으로 인식하고 해당 통신을 차단하는 경우에도 이 오류가 발생하는 것을 보았습니다.
해결
이 문제는 라이선스 서버와 라이선스 요청이 방화벽을 통과하도록 허용하도록 방화벽 설정을 변경하여 해결할 수 있습니다. 서버에 지정된 포트를 개방하거나 Foundry Licensing Tools(FLT) 내의 RLM 서버 프로그램이 서버를 통해 통신하도록 허용하면 됩니다.
자세한 설정 방법은 Q100216: 방화벽을 통해 라이선스 서버를 사용하는 방법을 참조하세요.
네트워크가 매우 제한적이라면 ISV가 실행할 포트를 설정하고 방화벽을 통과하도록 허용하는 것이 좋습니다. 자세한 내용은 다음 문서에서 확인할 수 있습니다. Q100374: RLM 서버가 전용 ISV 포트를 사용하도록 설정하는 방법
추가 도움말
여전히 문제가 지속되면 지원 티켓을 생성하여 발생한 정확한 문제와 해결 방법을 알려주세요. 서버 및 클라이언트 시스템 모두에 대한 Foundry License Utility(FLU) 진단 출력 파일을 첨부해 주세요.
지원 요청을 여는 방법에 대한 자세한 내용은 다음 문서를 참조하세요. Q100064: 지원 티켓을 제기하는 방법
라이선스 진단 로그를 생성하는 방법에 대한 자세한 내용은 다음 문서를 참조하세요. Q100105: 라이선스 문제 해결을 위해 FLU를 통해 라이선스 진단 로그를 생성하는 방법
우리는 문제로 불편을 끼쳐 드려 죄송합니다
이유를 알려주세요