症状
フローティング/サーバー ライセンス ファイルに無効なホスト名または IP アドレスが含まれている場合、またはサーバー マシンが自身のホスト名を解決または接続できない場合、ライセンス サーバーはネットワーク上でライセンスを起動したりフローティングしたりすることができません。
この問題が発生すると、 Foundry Licensing Utility (FLU) 8.0 以降では、ライセンス サーバーページに「サーバー ライセンス ホスト名が一致しません」というエラー メッセージが表示されます。
RLMサーバログに次の警告メッセージが表示されます。
06/19 11:50 (foundry) WARNING: No license file for this host (serverName)
06/19 11:50 (foundry) The hostname in the license file(s)
06/19 11:50 (foundry) may be incorrect
原因
この問題の主な原因は 2 つあります。ライセンス ファイル内のホスト名が正しくないことと、マシンのホスト名の問題です。
ライセンスファイル内のホスト名が正しくありません
フローティング ライセンスの最初の行 (HOST 行) には、ライセンスをフローティングするサーバー マシンに関する情報が次の形式で含まれています。
HOST <server_name> <System_ID> <port number>
- <server_name> は、サーバーマシンのローカルホスト名、完全修飾ドメイン名 (FQDN)、または IP アドレスです。
- <System_ID> は、ライセンスが生成されるシステムIDです。これはマシンの有効なMACアドレスである必要があり、編集するとライセンスが無効になります。
- <ポート番号> は、メインの RLM サーバープロセスが実行されるポートです。Foundry ライセンスFoundry 、他の RLM サーバーとの競合を避けるため、HOST 行にポート 4101 を指定して発行されます。
Foundry Licensing Utility (FLU) がフローティングライセンスをインストールすると、<server_name> のテキストがマシンのホスト名に置き換えられます。インストールされたライセンスのホスト行は次のようになります。
HOST redserver1 001122334455 4101
インストールされたライセンスのホスト名が正しくない場合、RLMサーバーは実行できません。主な原因は2つあります。
- ライセンスが手動でインストールされ、<server_name>フィールドがサーバーのホスト名またはIPアドレスで更新されていない場合
- コンピュータがネットワーク間を移動し、ライセンスのインストール時に使用したホスト名が現在のネットワーク上で有効でない場合
ホスト名の問題
サーバーを実行するには、マシンがライセンスファイル内のホスト名を使用して自身と通信できる必要があります。ファイル内のホスト名が正しくても、マシンがそのホスト名を使用して自身と通信できない場合、またはマシンがホスト名を見つけられない場合、RLMサーバーは起動できません。
これは、マシンまたはネットワークでDNSの問題が発生した場合に発生する可能性があります。macOSマシンをライセンスサーバーとして使用し、すべての共有設定をオフにした場合によく発生する問題です。
解決
.local を含む macOS ホスト名
これは、ホスト名が.localで終わり、共有設定がオフになっているmacOSマシンでよく発生する問題です。通常、サーバーマシンのシステム環境設定で「共有サービス」のいずれかをオンにすることで解決できます。
- システム環境設定を開く
- 「共有」をクリックし、「ファイル共有」のボックスにチェックを入れます。
- FLUを再度起動し、 「ライセンスサーバー」 > 「コントロールサーバー」に移動します。これでサーバーを再起動できるはずです。
一般的なガイダンス
この問題を解決するには、ライセンスに有効なホスト名があり、マシンがそれ自体と通信できることを確認する必要があります。
ステップ1. サーバーマシンのホスト名を確認する
現在のホスト名は、ターミナルまたはコマンドプロンプトで「hostname」コマンドを実行することで確認できます。ホスト名をメモしておいてください。
ステップ2. ライセンスファイル内のホスト名を確認する
FLUのライセンスで使用されているホスト名を確認するには、 「ライセンス」 > 「インストール済みを表示」をクリックします。有効なホスト名を持つライセンスは「有効なライセンス」セクションに表示され、無効なホスト名を持つライセンスは「無効なライセンス」セクションに表示されます。
ライセンスをクリックすると、ライセンス、マシン上の場所、無効の理由(この場合は「ホストおよび/またはベンダーの仕様が無効です」)が表示されます。
ステップ3. 必要に応じてライセンスファイルを更新する
ファイル内のホスト名がマシンのホスト名または IP アドレスと異なる場合は、サーバーを実行する前に更新する必要があります。
- 「ライセンスのインストール場所」フィールドをクリックすると、ライセンスディレクトリのファイルブラウザウィンドウが開きます。
- ライセンスファイルをテキストエディタで編集し、ホスト行を正しいホスト名に更新します。
注意: ライセンスのホスト行にまだ <server_name> がある場合は、ファイルを別のディレクトリに移動し、FLU を使用してインストールすることができます。ライセンス>インストールをクリックし、ファイルを選択してインストールをクリックします。
- もう一度「ライセンス」 > 「インストール済みを表示」に移動し、更新ボタンをクリックします。FLUはライセンスが有効かどうかを再度確認します。
ライセンスが有効になったら、サーバーを起動してみてください。 「ライセンスサーバー」 > 「コントロールサーバー」をクリックし、 「起動」または「再起動」ボタンが表示されたらクリックしてください。それでもエラーメッセージが表示される場合は、マシンのホスト名またはDNSに問題があります。
ステップ4. ホスト名の問題を確認して修正する
マシン上でコマンドプロンプトまたはターミナルを開き、次のコマンドを実行して、マシンが自身のホスト名を解決できるかどうかを確認します。
ping serverName
serverName は手順1で確認したマシンのホスト名です。Ctrl+C で ping をキャンセルできます。
pingで100%のパケットロスが報告された場合、またはホスト名を解決できない場合は、ホスト名またはDNSに問題があり、ライセンスサーバーの起動が妨げられている可能性があります。この問題を解決するには、システム管理者に相談する必要があるかもしれません。
次のステップ
マシンおよびネットワーク上のホスト名または DNS の問題を解決できない場合は、システム管理者に問い合わせてください。
それでも問題が解決しない場合やサーバーを起動できない場合は、サポート チケットを発行し、次の情報を含めてください。
- アプリケーションおよび/またはFLUからのエラー/警告メッセージのスクリーンショット
- マシンのライセンス設定を確認するために、FLUから取得した診断ファイルが必要です。 ライセンスに関する問題のトラブルシューティングのため、Q100105「FLUを使用してライセンス診断ログを生成する方法」をご覧ください。
さらに詳しく
ライセンスの詳細については、Foundryライセンスオンラインヘルプおよびライセンスサーバー管理セクションを参照してください。
サポート ポータルの次の記事には、ライセンス サーバーの設定方法とマシン上のライセンスの表示方法に関する情報が記載されています。
私たちはそれを聞いて申し訳ございません
理由をお聞かせください