症状
個人ログインベースのライセンスを使用してNukeの以前のバージョンを起動しようとすると、ライセンス ダイアログにライセンス有効期限の警告メッセージが表示される場合があります。
有効期限が切れると、 Nuke個人ログインベースのライセンスをチェックアウトできなくなり、起動できなくなります。
原因
ライセンス システムに必要なサーバー側の変更により、製品とサーバー間の通信に影響が生じ、以前の製品バージョンに影響が出ました。
その結果、有効なライセンスが利用可能であるにもかかわらず、ローカル ライセンス トークンが更新を試行すると (37 日ごと)、個別のライセンスのチェックアウトが失敗するようになりました。
この問題は、すべてのオペレーティングシステムのログインベースのライセンスと、2025年5月20日より前にリリースされたNukeバージョンにのみ影響を及ぼしました。最新のNukeバージョンではこの問題は発生しないはずです。その他のFoundry製品およびライセンスタイプには影響はありません。
解決
Nukeの最新バージョンではこの問題は発生しません。アップグレード可能な場合は、以下のNukeファミリー製品のいずれかをダウンロードしてインストールすることをお勧めします。
- 16.0v3以上
- 15.2v3以上
- 15.1v8以上
- 15.0v8以上
- 14.1v8以上
最新のNukeファミリー製品バージョンは、こちらからダウンロードできます: nuke
回避策
現時点でNukeファミリー製品の最新バージョンにアップグレードできない場合は、次の 2 つの方法のいずれかで回避できます。
定期的な手動ライセンストークンの更新
回避するには、個人ログイン ライセンス システムからログアウトし、マシンからトークン フォルダを削除して再度ログインする必要があります。
注: ローカル ライセンス トークンが更新されるたびに、これを 37 日ごとに繰り返す必要があります。
これを行う方法に関するステップバイステップガイドは、こちらにあります: Q100285: 個人ログインベースのライセンスに関する問題を解決するための初期手順
注:表示されている警告は、お使いのマシン上の特定のライセンストークンの有効期限です。これは、ライセンス全体の有効期限を反映したものではありません。
環境変数を使用して新しいNuke証明書バンドルファイルを指定する
FN_CURLOPT_CAINFO環境変数を設定して、より新しいNuke証明書バンドル ファイルを指すようにすると、上記の定期的な手動ライセンス トークン更新手順を実行する必要がなくなります。
注意: この環境変数を設定する前に、既存のライセンス トークンを削除する必要があります。
これを実装するには、この記事のガイダンスに従ってください: Q100720: 最新のNukeバージョンにアップグレードせずにログインベースのライセンスの問題を回避する方法
さらなる支援
この記事に記載されている手順を実行した後も問題が引き続き発生する場合は、サポート チケットを開いて、発生している問題とこれまでに行ったトラブルシューティング手順を、エラー メッセージのスクリーンショットとともにお知らせください。
サポート チケットを開く方法の詳細については、 「Q100064: サポート チケットの発行方法」の記事を参照してください。
私たちはそれを聞いて申し訳ございません
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