Q100235: 「ライセンスサーバーとの通信エラー」ライセンスエラーメッセージを解決する方法

症状

フローティング ライセンス サーバーを設定し、コンピューターをライセンス サーバーにポイントした後、プログラムの実行に失敗し、次のいずれかのエラー メッセージが表示されます。

ライセンスサーバーとの通信エラー (-17)

サーバーで接続が拒否されました (-111)
または
ライセンスサーバーとの通信エラー (-17)
ネットワークからの読み取りエラー (-105)

原因

このエラー メッセージは、サーバーが実行されていない場合、またはライセンス サーバーとクライアント マシン (ライセンスを要求しているコンピューター) の間にファイアウォールがある場合に表示されます。

ファイアウォールは、ライセンス要求が使用するポートを閉じるか、サーバー上の承認されたプログラムのみが他のコンピューターと通信できるようにすることで、ライセンス要求をブロックしている可能性があります。

顧客のネットワーク セキュリティが RLM トラフィックを疑わしいと認識し、この通信をブロックした場合にも、このエラーが発生することがあります。

解決

この問題は、ライセンスサーバーとライセンスリクエストがファイアウォールを通過できるようにファイアウォール設定を変更することで解決できます。これは、サーバーの指定ポートを開くか、 Foundry Licensing Tools (FLT) 内の RLM サーバープログラムがサーバー経由で通信できるようにすることで実行できます。

設定方法の詳細については、 「Q100216: ファイアウォール経由でライセンス サーバーを使用する方法」を参照してください。

ネットワークが厳重にロックされている場合は、ISV が実行するためのポートを設定し、ファイアウォールも通過できるようにすることをお勧めします。設定方法の詳細については、こちらの記事をご覧ください: Q100374: RLM サーバーが専用の ISV ポートを使用するようにする方法

さらなる支援

引き続き問題が発生する場合は、サポートチケットを作成し、発生した問題の詳細と実行したトラブルシューティング手順をお知らせください。サーバーマシンとクライアントマシンの両方について、 Foundryライセンスユーティリティ(FLU)の診断出力ファイルを添付してください。

サポートリクエストの提出方法の詳細については、こちらの記事をご覧ください: Q100064: サポートチケットの提出方法

ライセンス診断ログを生成する方法の詳細については、次の記事を参照してください: Q100105: ライセンスの問題をトラブルシューティングするために FLU 経由でライセンス診断ログを生成する方法

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