症状
チャンネル > 転送 を選択してテクスチャ転送を実行した後、新しいオブジェクトのペイントノードが空になり、転送が失敗したように見えることがあります。一方、クラウドやタイルなど、画像データを含む他のノードは正常に転送されています。
しかし、ユーザーがカメラをアセットに非常に近づけると、欠落していたペイントデータが表示され、ズームアウトすると再び消えてしまいます。以下はテクスチャ転送が完了した例ですが、テクスチャとして使用されているクラウドノードとマスクとして使用されているチェッカーボードノードは表示されていますが、ペイントノードで覆われるべき透明領域は透明なままです。ユーザーがズームインすると、ペイントデータが再び表示されます。
原因
この問題は、次の既知のバグによって発生します。
ID 555335 - 16k 16ビットチャンネルのチャンネル転送では、結果のペイントノードで最高解像度のミップマップのみが生成される可能性があります。
Mari 、他の3Dパッケージやビデオゲームと同様に、パフォーマンス向上とエイリアシングアーティファクトの軽減のためにミップマップを使用しています。このバグにより、アセットを遠くから見る際に使用される低解像度のミップマップが作成されません。最高解像度の画像のみが利用可能であるため、ユーザーがオブジェクトにズームインした際に、本来あるべきタイミングでミップマップが表示されます。
解決
ミップマップが欠落している場合は、 Mari内の任意のプロセスを起動して、影響を受けるペイントノードにミップマップを再作成できます。これを行う方法はいくつかありますが、以下の例の最初の 2 つは元のノードツリーを復元できます。
方法 1:影響を受けるペイント ノードを 1 つ選択し、右クリック > [編集] > [ペイント ノードにベイク処理] を選択します。
注:方法 1 は、個々のペイント ノードごとに繰り返す必要があります。
方法 2: UV ビューで、ブラシの半径を大きくしてすべての UV をカバーし、乗算ペイント モードですべてのペイント ノードのすべての UV を白くペイントします。
方法 3:チャネル ノードの前にベイク ポイント ノードを追加してベイクします。
方法 4:エクスポート マネージャを使用してテクスチャ転送チャネルをエクスポートし、テクスチャをペイント ノードに再インポートします。
さらなる支援
問題が発生した場合は、サポート チケットを作成し、この記事で要求されている情報を提供してください。
Q100090: Mari問題を報告する際にサポートに送信する情報
サポート チケットを開く方法の詳細については、次の記事を参照してください。
Q100064: サポートチケットを発行する方法
私たちはそれを聞いて申し訳ございません
理由をお聞かせください