症状
RLM サーバーを起動しようとすると、サーバーが正しく起動せず、ライセンスがフローティングされる代わりに、次のエラーが表示されます。
==> 05/25 16:20 (rlm) Port 4101 in use, waiting...
==> 05/25 16:20 (rlm) Port 4101 in use, waiting...
==> 05/25 16:20 (rlm) Port 4101 in use, waiting...
==> 05/25 16:20 (rlm) Port 4101 still in use, giving up.
==> Error connecting to "rlm" server
==> Connection attempted to host: "<hostname>" on port 4101
==> Connection refused at server (-111)
==> Cannot connect to server (comm: -4)
原因
4101はライセンスファイルのHOST行で指定されているポートで、クライアントマシンがライセンスを要求する際に使用するポートです。Foundry Foundryは、他のRLMサーバーとの競合を避けるため、デフォルトでHOST行のポート4101を使用して発行されます。
ポートが使用中であるというエラーが表示される場合、これは通常、このマシン上にポート 4101 からフローティングしている別の RLM プロセスがあることを意味します。
これが発生する理由の 1 つは、サーバー上で実行されていた最後のFoundry RLM セッションが正常に終了しなかったことです。
解決
最初に確認する必要があるのは、このサーバー上の他のベンダーがポート 4101 を使用していないことです。
このポートを使用しているものが他にないことを確認したら、マシン上で古いFoundry RLMプロセスが実行されていないことを確認してください。以下の手順でサーバーの実行を完全に停止できます。
- Foundryライセンスユーティリティ(FLU)を起動する
- 「ライセンスサーバー」と「コントロール」タブに移動します
- 可能であればサーバーを停止する
- 「ライセンスサーバー」と「アンインストール」オプションに移動し、アンインストーラーを実行します。
- 次のインストール手順に従ってサーバーを再インストールします: Q100360: フローティング/サーバーライセンス用のサーバーツールのインストール方法
- サーバーを起動する
ヘッドレス マシンで FLU を使用している場合は、 ここでサーバーを停止および起動する手順を参照してください。
FLU を使用していない場合は、次の手順に従って rlmutil 経由でサーバーを停止できます。
- コマンドプロンプトまたはターミナルを開きます
- 次のコマンドでrlmutilに移動します
Windows:cd C:\Program Files\The Foundry \LicensingTools8.0\bin\RLM
Mac:cd /Applications/TheFoundry/LicensingTools8.0/bin/RLM/
Linux:cd /usr/local/ foundry /LicensingTools8.0/bin/RLM
- サーバーを停止するには、rlmdown コマンドを使用します。
例:rlmutil rlmdown foundry -c 4101@<hostname>
詳細については、次を参照してください: Q100659: rlmutil とは何ですか? また、どのように使用できますか?
さらに詳しく
引き続き問題が発生する場合は、サポート チケットを作成して、発生した問題の正確な内容と実行したトラブルシューティング手順をお知らせください。
サポート リクエストを開く方法の詳細については、次の記事を参照してください。
rlmutil とそのコマンドの詳細については、次のドキュメントを参照してください: Q100659: rlmutil とは何ですか? どのように使用できますか?
ライセンスサーバーの管理方法の詳細については、この記事をご覧ください。
私たちはそれを聞いて申し訳ございません
理由をお聞かせください