症状
macOS 上のModoにプラグインまたはキットをインストールすると、 「コンテンツ ディレクトリが見つかりません」というメッセージが表示され、ディレクトリが見つからないか制限されているため、 Modoインストールを中止したことが説明されます。
画像1: 「コンテンツディレクトリが見つかりません」というメッセージ
原因
Modo 、プラグインまたはキットのコンテンツをインストールするために、 /Library/Application Support/Luxology/ディレクトリへの完全な「読み取りおよび書き込み」権限を必要とします。プラグインまたはキットをインストールするユーザーがそのフォルダへの読み取りおよび書き込み権限を持っていない場合、インストールは中止されます。
解決
まず、 /Library/Application Support/Luxology/Content/Assetsディレクトリが存在することを確認してください。存在しない場合は、 Modo製品ダウンロードページからコンテンツパックをダウンロードしてインストールしてください。これらのパックをインストールすると、このディレクトリが存在するはずです。
これらのコンテンツパックをインストールしてもこの問題が引き続き発生する場合、またはこのディレクトリが既に存在する場合は、該当するフォルダに読み取りおよび書き込み権限を設定する必要があります。これを行うには、以下の手順に従ってください。
1. Finderウィンドウで、 「ライブラリ」 > 「アプリケーション サポート」 > 「Luxology」に移動します。
2. Luxologyフォルダを右クリックし、 「情報を見る」を選択します。
3. 右下にある南京錠をクリックし、パスワードを入力して設定を編集します。
4. 「共有と権限」セクションで、ユーザーの横に「読み取りと書き込み」と表示されていることを確認します。表示されていない場合は変更してください。
5. ギアドロップダウンをクリックし、 「同梱のアイテムに適用」を選択します。
これにより、プラグインやキットのインストールに必要な、 Luxologyフォルダー内の任意のディレクトリへの書き込み権限でModo起動できるようになります。
これでプラグインまたはキットを正常にインストールできるようになり、プラグインまたはキットをロードするためにModo再起動を求めるメッセージが表示されます。
さらなる支援
この記事に記載されている手順を実行する際に問題が発生した場合は、サポートチケットを作成し、発生している問題と、これまでに行ったトラブルシューティング手順をお知らせください。サポートチケットの作成方法の詳細については、次の記事をご覧ください: Q1000064:サポートチケットの発行方法。
私たちはそれを聞いて申し訳ございません
理由をお聞かせください