症状
場合によっては、ビューが壊れている、または空になっているように見え、ナビゲーションやジオメトリの表示に反応しないことがあります。この記事では、ビューがアクティブであることを確認する最適な方法、ビューポートカメラの制御を取り戻す方法、そしてジオメトリが表示されていることを確認する方法について説明します。
この動作は、大きなアーカイブやワークステーション間でやり取りされたアーカイブでよく発生します。その場合、以下のスクリーンショットのように、正投影ビューはほぼ空のタブのように見えますが、他のビュー(主にUVビュー)ではアセットが表示されていることがよくあります。
原因
Mariのような複雑なソフトウェアでは、アセットの可視性、クリッピングプレーン、カメラがアセットから遠く離れているなど、ビューの一部またはすべてが期待どおりに動作しない理由は数多く考えられます。ユーザーが意図せず、間違ったショートカットを使用するなどして、ビューが空になったり応答しなくなったりする動作を引き起こす可能性があります。また、潜在的なバグも考慮する必要があります。
最善のアプローチは、ビューに影響するすべてのプロセスを確認し、それらが正しく設定されていることを確認することです。
解決
ビューの確認はまだ機能しています
最初のステップは、ビューにMariキャンバスがまだ含まれているかどうかを確認することです。これを行うには、次の手順を実行します。
- [表示] > [パレット] > [ライト]を選択して、ライトパレットを開きます。
- 環境ライトをオンにします。
- このパレットで、 [環境] > [テクスチャ] > [イメージ]を選択し、環境ライトで使用する HDRI イメージの 1 つを選択します。
- 同じメニューで、 [背景]が[表示]に設定されていることを確認します。
デフォルトでは環境ライトオプションはオフになっているため、 Mariキャンバスが存在するかどうか、またナビゲーションショートカットに反応しているかどうかが分かりにくくなっています。しかし、オンにすると、キャンバスが存在し、回転できることがはるかに分かりやすくなります。
以下はプロセスを示す画面録画です。
ペイントバッファスケールのリセット
この段階でビューポートがまだ反応する場合は、ペイントバッファでズームインまたはズームアウトしすぎたために、誤ってジオメトリを見失った可能性があります。これは高解像度のプロジェクトで作業しているときによく発生するため、ジオメトリを見失った場合はペイントバッファのスケールをリセットしてみることが重要です。
これを行うには、次の画面記録に示すように、ツール ツールバーのペイント バッファ ツールグループから [ズーム ペイント バッファ] 虫眼鏡ツールを選択し、ツール プロパティツールバーの[リセット]ボタンを選択します。
資産のフレーミングとカメラの再設定
カメラを移動している間に資産を見失ってしまう可能性もあります。
ビューをアセットの中心に配置するには、 [カメラ] > [すべて表示]を選択します。
それでもアセットが表示されない場合は、 「カメラ」>「カメラをリセット」も試してみてください。これにより、キャンバスツールバーの「近距離」 、 「遠距離」 、 「視野角」の設定がリセットされ、ビューに予期せぬ影響を与える可能性があります。例えば、 「近距離」のクリッピングプレーン設定が高すぎると、シーンが見えなくなってしまう可能性があります。
カメラのクリッピング距離の調整
場合によっては、カメラのデフォルトのクリッピング距離によってシーンが見えなくなることがあります。正投影ビューではカメラのクリッピング距離を変更できないため、パースビューでシーンが見えない場合、このトラブルシューティング手順が最も役立ちます。
パースペクティブビューカメラのクリッピング距離の変更は、 Mari UIの上部にあるキャンバスツールバーで行います。キャンバスツールバーを有効にするには、既存のツールバーを右クリックします。すると、すべてのパレットとすべてのツールバーを含むメニューが表示されます。キャンバスツールバーが有効になっていることを確認してください。
キャンバス ツールバーを有効にすると、 NearとFarという 2 つの入力フィールドとFoV (視野) が表示されます。
シーンの規模が特に小さい場合は、 Near値を小さく (例: 0.001) すると効果的であり、シーンの規模が特に大きい場合は、 Far値を大きく (例: 100,000.000) すると効果的です。
クリッピング距離をリセットする必要がある場合は、 「カメラ」>「カメラをリセット」を選択してください。これにより、キャンバスツールバーの「近距離」 、 「遠距離」 、 「視野角」の設定がリセットされます。
カメラのロック解除
ナビゲーションツールバーは、カメラの動きを様々な方法で制限することができ、完全にロックすることもできます。ナビゲーションツールが編集されると、アイコンがオレンジ色に変わり、ユーザーはアセットを見つけるためにナビゲートできなくなる場合があります。
カメラのロックを完全に解除するには、ユーザーは「ナビゲーション設定をデフォルトにリセット」という左端のボタンを押す必要があります。
資産の可視性
Mariは3つの「表示モード」があり、現在の選択モードに応じて異なります。誤って使用すると、ユーザーはアセットを表示できないという印象を受ける可能性があります。
例えば、ユーザーが面モードでオブジェクト全体を選択し、 「選択項目を非表示」を選択して非表示にした場合、オブジェクトパレットからそのオブジェクトを表示できなくなります。これは、オブジェクト自体は技術的には表示されているものの、面が非表示になっているためです。
現在の選択モードに関係なく、すべての面、パッチ、およびオブジェクトを表示するには、選択 > すべて表示を使用する必要があります。
ビューをリセットするための新しいオブジェクトの追加
上記のトラブルシューティング オプションがどれも機能しない場合は、シーンに大きな 3D モデルを追加することで、ビューを強制的に完全に再読み込みできることが、一部のユーザーから報告されています。
シーンに新しいオブジェクトを追加するには、ユーザーはオブジェクトパレットを選択し、 [オブジェクトの追加]ボタンをクリックします。
追加した 3D モデルは、すべての軸で 30cm より大きくなる必要があります。これは、サンプルプロジェクトのサイズの約 2 倍に相当します。サンプル プロジェクトは、 [ヘルプ] > [サンプル プロジェクトの作成] を選択して参照用に作成できます。
ナビゲーションの設定
ナビゲーションが予期しない動作をする場合、ユーザーは[編集] > [環境設定] > [ナビゲーション]を選択して、すべてのナビゲーション設定をデフォルトにリセットしたり、ナビゲーション関連のショートカットを変更するなどの追加効果を持つ [コントロール タイプ]を変更したりすることもできます。
シェーダーの問題
ビューをレンダリングするシェーダーが突然アセットを見つけられなくなり、レンダリングに表示されなくなる可能性もあります。上記の提案を試しても問題が解決しない場合は、 Tools > Shader Console > All / Reload Shader を選択することをお勧めします。どちらのボタンもシェーダーを再読み込みし、アセットを再び見つけて表示できるようになる可能性があります。
さらなる支援
問題が発生した場合は、サポート チケットを作成し、この記事で要求されている情報を提供してください。
Q100090: Mari問題を報告する際にサポートに送信する情報
サポート チケットを開く方法の詳細については、次の記事を参照してください。
Q100064: サポートチケットを発行する方法
私たちはそれを聞いて申し訳ございません
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