Q100531: How to fix "Server License Hostname Mismatch" when starting the server via FLU

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SYMPTOMS

A license server will not be able to start up and float licenses on a network if the floating/server license file contains an invalid hostname or IP address or if the server machine cannot resolve or contact its own hostname.

If this happens, the Foundry Licensing Utility (FLU) 8.0 and above will display error message saying "Server License Hostname Mismatch" on the License Server pages:

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and the following warning message will be displayed in the RLM server log

06/19 11:50 (foundry) WARNING: No license file for this host (serverName)
06/19 11:50 (foundry)          The hostname in the license file(s)
06/19 11:50 (foundry)          may be incorrect

 

CAUSES

There are two main causes of this problem - an incorrect hostname in the license file and hostname problems with the machine.

Incorrect hostname in license file

The first line of a floating/server license, the HOST line, contains information about the server machine that will float the licenses in the following format:

HOST <server_name> <System_ID> <port number>
  • <server_name> can be the local hostname, fully qualified domain name (FQDN) or IP address of the server machine
  • <System_ID> is the SystemID the licenses are generated for.  This has to be a valid MAC address for the machine and cannot be edited or the license(s) will be invalid
  • <port number> is the port that the main RLM server process will run on.  Foundry licenses are issued with port 4101 on the HOST line to avoid conflicts with other RLM servers.

When the Foundry Licensing Utility (FLU) installs a server/floating license the <server_name> text is replaced with the hostname of the machine.  The host line of an installed license will look like

HOST redserver1 001122334455 4101

 

If the hostname in the installed license is incorrect then the RLM server won't be able to run.  There are two main causes of this:

  • If a license is manually installed and the <server_name> field is not updated with the server hostname or IP address
  • If a computer moves between networks and the hostname used when the license was installed is not valid on the current network

 

Hostname problems

In order for the server to run, the machine needs to be able to communicate with itself using the hostname in the license file.  If the hostname in the file is correct but the machine cannot contact itself using that hostname, or the machine cannot locate a hostname then the RLM server won't be able to start up.

This can happen if you have DNS problems with the machine or network.  It can be a common issue when using a macOS machine as a license server with all sharing settings turned off.

 

RESOLUTION

macOS hostnames with .local

This can be a common problem on macOS machines with hostnames ending in .local and sharing settings turned off.  This can usually be fixed by turning on any of the "sharing services" within the System Preferences on the server machine.

  1. Open System Preferences
  2. Click on Sharing and check the box for "File Sharing"
  3. Launch the FLU again and go to License Server > Control Server. You should now be able to Restart the server.

 

General Guidance

In order to fix the problem you need to check that the license has a valid hostname and that the machine can communicate with itself.

Step 1. Check the hostname of the server machine

You can find the current hostname by running a "hostname" command in a Terminal or Command Prompt.  Make a note of the hostname.

 

Step 2. Check the hostname in the license file

You can check the hostname used in the license from the FLU by clicking on Licenses > View Installed.  Licenses with valid hostnames appear in the Valid Licenses section, licenses with invalid hostnames appear in the Invalid Licenses section.

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Clicking on a license will show the license, where it is on the machine and the reason why its invalid, in this case "host and/or vendor specification is not valid"

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Step 3. Update the license file if required

If the hostname in the file is different to the hostname or IP address of the machine it will need to be updated before the server can run.

  1. Click on the "License Install Location" field to open a file browser window in the license directory

  2. Edit the license file with a text editor and update the host line to have the correct hostname

    NOTE: If the license still has <server_name> on the host line you can move the file to a different directory and install it using the FLU by clicking on Licenses > Install then select the file and click Install

  3. Go to LicensesView Installed again and click on the refresh button.  The FLU will check again if the licenses are valid.

If the license is now valid you can try to start the server.  Click on License ServerControl Server and then on Start or Restart buttons if they appear.  If you still get the error message then there is a hostname or DNS problem with the machine.

 

Step 4. Check and fix hostname problems

Check if the machine can resolve its own hostname by opening a Command Prompt or Terminal on the machine and running the following command

ping serverName

where serverName with the hostname of your machine from Step1.  You can cancel the ping with Ctrl+C.

If the ping reports 100% packet loss or it cannot resolve the hostname then it implies there is a hostname or DNS problem preventing the license server from starting.  You may need to speak to your system administrators to fix this.

 

 

NEXT STEPS

Please contact your system administrator if you cannot resolve the hostname or DNS issues on the machine and network.

If this does not resolve the problem and/or you cannot get the server to start up then please raise support ticket and include the following:

 

 

FURTHER READING

For more information about licensing please see the Foundry Licensing Online Help and the License Server Admin section

The Support Portal has information on how to setup a license server and how to view the licenses on your machine in the following articles:

 

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