When working within Nuke, there can be times where the user interface seemingly freezes or hangs briefly, and then resumes.
If you encounter this behavior and the only symptom is that you are working within a large/complex project, the cause could be related to your autosave settings.
CAUSE
Nuke has two Preferences that control the frequency of autosaves. These options are listed below, accompanied by their default values and a brief description of their functionality:
idle comp autosave - default is 5 seconds
When Nuke does not receive any input from the mouse or keyboard for this number of seconds, an autosave file is made.
force comp autosave - default is 30 seconds
If this number of seconds have passed without an autosave being created, Nuke will force an autosave file to be generated.
When a Nuke script is quite large and complex, the amount of time it can take to save could be longer that these default durations allow.
This occurs as the Nuke script (.nk) save file itself is taking longer to generate than the time given to write the autosave (.autosave) file. As a byproduct of this process, Nuke lags for a moment as it waits for both processes to finish concurrently.
RESOLUTION
We suggest setting the force comp autosave to a higher amount to allow sufficient time for the Nuke script to save, before the autosave saves. This can be changed with the Preferences menu, under the General tab within the force comp autosave after field.
FURTHER HELP
If the slowness still occurs after this change, then there are a couple of things we would suggest trying in order to troubleshoot the problem further:
- As this could be related to a full disk cache, we would suggest checking and clearing the disk cache, as outlined in the following article:
Q100043: How to clear your Nuke/NukeX/Nuke Studio/Hiero cache
- This could also be related to Nuke's frame server but, to see if it is, we would recommend disabling it. More information about disabling Nuke's frame server can be found here:
Q100378: How to disable the Frame Server for Nuke, Nuke Studio and Hiero
If you have tried all of the steps in this article, and you are still encountering the problem, then please open a Support ticket and let us know the exact issue you are encountering and the troubleshooting steps you have taken so far. For more information on how to open a Support ticket, please refer to the following article:
We're sorry to hear that
Please tell us why
SYMPTOMS