SYMPTOMS
In some instances users may find that the View appears to be broken or empty, and it does not seem to respond to navigation or display geometry. This article describes the best methods to check that your View is still active, how to take back control of the viewport camera, and ensure your geometry is visible.
This behaviour often presents in large archives or archives that have been passed around workstations. In that case, the Orthographic View appears almost as though it is an empty tab as in the screenshot below, whilst the other views (primarily UV view) often still show the assets as visible:
CAUSE
With software as complex as Mari, there can be many reasons why any or all of the Views don't behave as expected, such as the visibility of the asset, clipping planes, or the camera being moved far from the asset. A user may unintentionally trigger a behaviour that causes the View to appear empty or unresponsive, such as by accidentally using the wrong shortcut, and there are also potential bugs to take into account.
The best approach is to go through every process that affects the View and ensure they are set correctly.
RESOLUTION
CONFIRMING THE VIEW STILL WORKS
The first step is to check that your View still contains the Mari canvas. To do this:
- Open the Lights palette by selecting View > Palettes > Lights.
- Turn on the Environment light.
- In this palette, select Environment > Texture > Image and select one of the HDRI images to use it in the Environment light.
By default, the Environment light option is turned off, making it hard to tell whether the Mari canvas exists and whether it is responding to navigation shortcuts. However, you can see that with it switched on, it is far easier to tell that the canvas still exists and can be rotated.
Here is a screen recording demonstrating the process:
RESETTING THE PAINT BUFFER SCALE
If your viewport still responds at this stage, it is likely that you have accidentally lost sight of your geometry by zooming too far in or out on your Paint Buffer. This often happens while working on high-resolution projects, so it is important to try resetting your Paint Buffer scale should you lose your geometry.
To do this, select the Zoom Paint Buffer magnifying glass tool from the Paint Buffer Tools group on the Tools Toolbar, and select the Reset button, as illustrated in this screen recording:
FRAMING THE ASSET AND RESETTING THE CAMERA
It's also possible to lose sight of your asset while moving the camera.
To recentre your View into your asset, please select Camera > View All.
Then, if the asset is still not visible, Camera > Reset Camera should also be attempted. This will reset your Near, Far, and FoV settings from the Canvas Toolbar, which can also affect the View unexpectedly. For example, if the Near clipping plane setting is too high, the user can make their scene invisible.
ADJUSTING THE CLIPPING DISTANCE OF THE CAMERA
In some cases, you may find that the default clipping distance of the camera can make your scene invisible. In Orthographic View, the clipping distance of the camera cannot be changed, so this troubleshooting step will be most useful if you cannot see your scene in Perspective View.
To change the clipping distance of the camera in Perspective View, you need to navigate to the Canvas Toolbar, found at the top of your Mari UI, just above your 3D Viewport and other Palettes. If you need to enable the Canvas Toolbar, you can do so by navigating to the toolbars section of the UI and right clicking. This will bring up a menu with all the Palettes and all of the toolbars. Ensure that the Canvas Toolbar is enabled.
Once the Canvas toolbar is enabled, you will be able to see two input fields named Near and Far, as well as FoV (Field of View).
If your scene is particularly small in scale, it may help to make the Near value smaller (eg. 0.01, 0.001) and if your scene is particularly large in scale, it may help to make the Far value larger (eg. 10,000.000, 100,000.000).
If you need to reset your clipping distances, please select Camera > Reset Camera. This will reset your Near, Far, and FoV settings from the Canvas Toolbar.
UNLOCKING THE CAMERA
The Navigation Toolbar can be used to restrict camera movements in various ways, up to the point where it's fully locked. When the navigation tools have been edited, their symbols turn orange, and the user may be unable to navigate in order to find their asset.
To fully unlock the camera, the user must press the leftmost button, called Reset navigation settings to their default.
ASSET VISIBILITY
Mari has three "visibility modes" which are dependent on the current Selection Mode. If used incorrectly, the user may get the impression that it's impossible to make their asset visible.
For example, if a user selects his entire object while in Face Mode, and then hides it by selecting Hide Selected, they'll be unable to make the Object visible through the Objects palette. This is because the Object is technically still visible, while its faces are invisible.
To make all faces, patches, and objects visible, independently of the current Selection Mode, the user must use Selection > Show All.
ADDING A NEW OBJECT TO RESET THE VIEW
A few users have reported that when none of the above troubleshooting options work for them, they are able to force the View to fully reload by adding a large 3D model to the scene.
To add a new Object to the scene, the user can select the Objects palette and click the Add Object button:
The added 3D model should be larger than 30cm on every axis, which equates to about double the size of the Example Project, which can be created for reference purposes by selecting Help > Create Example Project.
NAVIGATION PREFERENCES
If navigation is behaving in unexpected ways, the user can also select Edit > Preferences > Navigation, where they can reset every navigation setting to its default or change the Control Type, which has additional effects such as changing navigation-related shortcuts.
SHADER ISSUES
It's also possible for the shader that renders the View to suddenly become unable to find the asset, so that it no longer exists in the render. So if the above suggestions haven't resolved your issue, it's worth selecting Tools > Shader Console > All / Reload Shader. Both will reload the shader, which may help it locate and display the asset again.
FURTHER HELP
If you are experiencing difficulties please create a support ticket and provide us with the information requested in this article:
Q100090: Information to send Support when reporting a Mari issue
For more information on how to open a Support ticket, please refer to this article:
Q100064: How to raise a support ticket
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