症状
如果浮动/服务器许可证文件包含无效的主机名或 IP 地址,或者服务器计算机无法解析或联系其自己的主机名,则许可证服务器将无法启动并在网络上浮动许可证。
如果发生这种情况, Foundry Licensing Utility (FLU) 8.0 将在许可证服务器页面上显示错误消息“服务器许可证主机名不匹配”:
并且 RLM 服务器日志中将显示以下警告消息
06/19 11:50 (foundry) WARNING: No license file for this host (serverName)
06/19 11:50 (foundry) The hostname in the license file(s)
06/19 11:50 (foundry) may be incorrect
原因
导致此问题的主要原因有两个 - 许可证文件中的主机名不正确以及计算机的主机名问题。
许可证文件中的主机名不正确
浮动/服务器许可证的第一行(HOST 行)包含有关将以以下格式浮动许可证的服务器计算机的信息:
HOST <server_name> <System_ID> <port number>
- <server_name> 可以是服务器计算机的本地主机名、完全限定域名 (FQDN) 或 IP 地址
- <System_ID> 是为其生成许可证的系统 ID。这必须是机器的有效 MAC 地址,并且无法编辑,否则许可证将无效
- <端口号> 是主 RLM 服务器进程将运行的端口。 Foundry许可证通过 HOST 线路上的端口 4101 颁发,以避免与其他 RLM 服务器发生冲突。
当Foundry Licensing Utility (FLU) 安装服务器/浮动许可证时,<server_name> 文本将替换为计算机的主机名。已安装许可证的主机行将类似于
HOST redserver1 001122334455 4101
如果安装的许可证中的主机名不正确,则 RLM 服务器将无法运行。造成这种情况的主要原因有两个:
- 如果手动安装许可证并且 <server_name> 字段未使用服务器主机名或 IP 地址更新
- 如果计算机在网络之间移动,并且安装许可证时使用的主机名在当前网络上无效
主机名问题
为了使服务器运行,计算机需要能够使用许可证文件中的主机名与自身进行通信。如果文件中的主机名正确,但计算机无法使用该主机名与自身联系,或者计算机无法找到主机名,则 RLM 服务器将无法启动。
如果您的计算机或网络存在 DNS 问题,则可能会发生这种情况。当使用 macOS 计算机作为许可证服务器并关闭所有共享设置时,这可能是一个常见问题。
解决
带有 .local 的 macOS 主机名
这可能是主机名以 .local 结尾且共享设置关闭的 macOS 计算机上的常见问题。通常可以通过打开服务器计算机上的系统偏好设置中的任何“共享服务”来解决此问题。
- 打开系统偏好设置
- 单击“共享”并选中“文件共享”复选框
- 再次启动 FLU 并转至许可证服务器>控制服务器。您现在应该能够重新启动服务器。
一般指导
为了解决该问题,您需要检查许可证是否具有有效的主机名以及计算机是否可以与自身通信。
步骤 1. 检查服务器计算机的主机名
您可以通过在终端或命令提示符中运行“hostname”命令来查找当前主机名。记下主机名。
步骤 2. 检查许可证文件中的主机名
您可以通过单击Licenses > View Installed来检查 FLU 中许可证中使用的主机名。具有有效主机名的许可证将显示在“有效许可证”部分中,具有无效主机名的许可证将显示在“无效许可证”部分中。
单击许可证将显示许可证、它在计算机上的位置以及其无效的原因,在本例中为“主机和/或供应商规范无效”
步骤 3. 如果需要更新许可证文件
如果文件中的主机名与计算机的主机名或 IP 地址不同,则需要更新服务器才能运行。
- 单击“许可证安装位置”字段以在许可证目录中打开文件浏览器窗口
- 使用文本编辑器编辑许可证文件并更新主机行以具有正确的主机名
注意:如果许可证在主机行上仍然有 <server_name>,您可以将该文件移动到其他目录并使用 FLU 安装它,方法是单击“许可证” > “安装” ,然后选择该文件并单击“安装” - 再次转至许可证>查看已安装,然后单击刷新按钮。 FLU 将再次检查许可证是否有效。
如果许可证现在有效,您可以尝试启动服务器。单击“许可证服务器” > “控制服务器” ,然后单击“启动”或“重新启动”按钮(如果出现)。如果您仍然收到错误消息,则表明计算机存在主机名或 DNS 问题。
步骤 4. 检查并修复主机名问题
通过打开计算机上的命令提示符或终端并运行以下命令,检查计算机是否可以解析自己的主机名
ping serverName
其中 serverName 是第 1 步中您计算机的主机名。您可以使用 Ctrl+C 取消 ping。
如果 ping 报告 100% 数据包丢失或无法解析主机名,则意味着存在主机名或 DNS 问题,导致许可证服务器无法启动。您可能需要与系统管理员联系来解决此问题。
下一步
如果您无法解决计算机和网络上的主机名或 DNS 问题,请联系您的系统管理员。
如果这不能解决问题和/或您无法启动服务器,请提出支持请求并包含以下内容:
- 来自应用程序和/或 FLU 的错误/警告消息的屏幕截图
- 您计算机上的 FLU 的诊断文件,以便我们可以检查计算机的许可设置。请参阅Q100105:如何生成许可证诊断文件
延伸阅读
有关许可的更多信息,请参阅Foundry Licensing Online Help和License Server Admin 部分
支持门户在以下文章中提供了有关如何设置许可证服务器以及如何查看计算机上的许可证的信息:
我们很遗憾听到
请告诉我们