创建支持服务单
关注

Q100421:Apple在macOS 10.14(Mojave)中弃用OpenGL和OpenCL

摘要

本文解释了Apple公布的OpenGL和OpenCL弃用公告将如何影响Foundry产品。

更多信息

Apple宣布他们正在弃用OpenGL和OpenCL ,但两者都将继续在他们即将推出的macOS版本10.14(Mojave)中运行。他们还说过了
不推荐使用的 API最终可能会从其操作系统的未来版本中完全删除。

从macOS 10.14开始, Apple推荐游戏和图形密集型应用程序采用Metal作为其原生GPU处理框架。

目前, macOS在其最新的Mac机器中支持OpenGL 4.1 ,我们每个产品的OpenGL要求如下:

Nuke / NukeX / Nuke Studio / Hiero / CaraVR - OpenGL 2.0
Mari - OpenGL 3.2+(或4.0+用于位移预览)
Modo - OpenGL 3.2
Colorway - OpenGL 3.2
注意: Katana目前不支持macOS。

Foundry产品仍然适用于macOS 10.14吗?

Apple对macOS 10.14的弃用警告意味着OpenGL和OpenCL将很快或者没有来自Apple的开发,但API仍将存在于即将推出的macOS 10.14版本中。

没有明确的时间表来确定何时完全删除这些API,或者它们在macOS 10.15及更高版本中可用的程度。

我们的产品团队已经开始研究在支持macOS 10.15及更高版本方面需要做出哪些改变。

根据应用程序的OpenGL / CL要求,10.14中OpenGL / CL的质量以及10.15及之后的可用性级别,我们建议保留在包含OpenGL / OpenCL的支持版本的macOS上,直到我们获得有关其含义的更多信息。我们的产品在10.15及以后。

Foundry产品是否会在未来支持Metal?

鉴于OpenGL和OpenCL将被弃用,并且某些时候将从macOS中删除,将需要使用Metal直接或间接支持GPU图形和计算。

为此所做的改变并非微不足道,我们正在评估最佳前进方案的选择。

请注意,我们的产品具有不同程度的OpenCL / OpenGL依赖性,并且这种支持的开发时间表因我们的产品而异。

这篇文章有帮助吗?
/

We're sorry to hear that!

Please tell us why.
24 人中有 19 人觉得有帮助

评论