创建支持服务单
关注

Q100234: Nuke 之间的插件兼容性

概括

Nuke版本之间的 NDK 插件兼容性以及 NDK 插件何时需要重新编译。

更多信息


任何Nuke Nuke同一分支的所有 v-releases 兼容。例如,如果您为Nuke 12.1v1 编译了一个插件,这将适用于 12.1v1 到 12.1v4,但它不适用于Nuke 12.0 版本或Nuke 12.2 版本,因为分支编号已更改。

虽然该版本有一个“Nuke 12”的名字,但在Nuke的 NDK 插件 API 方面有足够的变化,与 12.0 相比,它是一个新的主要版本。 Nuke 12.0 的插件Nuke 12.1 版本重新编译一样,您的Nuke 12.2 的 C++ 插件也需要针对Nuke 12.2v1 NDK 重新编译,以便它们在Nuke 12.2v1 中工作。
这也适用于OculaCara插件,它们也是针对特定的Nuke发布版本构建的。
以下文章详细介绍了Cara VR Nuke不同分支的兼容性: Q100233: Nuke不同分支之间的CaraVR

这篇文章有帮助吗?

我们很遗憾听到

请告诉我们
2 人中有 2 人觉得有帮助