创建支持服务单
关注

Q100234:不同版本的Nuke之间的插件兼容性

摘要

本文介绍了Nuke版本之间的NDK插件兼容性以及NDK插件何时需要重新编译。

更多信息


使用NDK C ++ API编译的任何Nuke插件通常都与Nuke的同一分支的所有v-release兼容。例如,如果您为Nuke 10.0v1编译了一个插件,这将适用于10.0v1到10.0v6,但它不适用于Nuke 9.0版本或Nuke 10.5版本,因为分支编号已更改。

这也适用于新的Nuke 11.1v1版本。虽然该版本有一个'Nuke 11'的名称,但在Nuke的NDK插件API方面有足够的变化,与11.0相比,它是一个新的主要版本。与Nuke 10.0的插件需要重新编译Nuke 10.5版本的方式相同,Nuke 11.0的C ++插件需要针对Nuke 11.1v1 NDK重新编译才能在Nuke 11.1v1中运行。

这也意味着在新版本的插件发布之前,Nuke 11.0的Cara VR和Ocula版本将无法与Nuke 11.1版本一起使用。我们正在考虑为Nuke 11.1发布Cara VR和Ocula,但目前还不能承诺。
以下文章解释了更多关于Cara VR与Nuke不同分支的兼容性Q100233:Nuke不同分支之间的CaraVR兼容性

这篇文章有帮助吗?
/

We're sorry to hear that!

Please tell us why.
1 人中有 1 人觉得有帮助

评论