创建支持服务单
关注

Q100190:Mac OS Sierra及更高版本上的Foundry产品的安装问题

摘要

在Mac OS Sierra及更高版本中安装Foundry产品会引发安装警告,因为我们不是已确定的开发人员。

更多信息

目前,在OS Sierra及更高版本上安装时,许多Foundry产品都会收到安装警告。在以前的操作系统版本中,您可以导航到首选项中的“安全和隐私”部分,并设置“允许从以下位置下载应用程序”:这将删除任何将来的安装警告。

此功能已从Sierra中删除,因此我们希望强调当前已知的安装解决方法。 Apple目前提供以下建议

如果您尝试打开未由标识的开发人员向Apple注册的应用程序,则会出现警告对话框。这并不一定意味着应用程序出了问题。例如,某些应用程序是在开发者ID注册开始之前编写的。但是,该应用尚未经过审核,并且macOS无法检查应用程序自发布以来是否已被修改或损坏。

分发恶意软件的常见方法是使用无辜的应用程序并在其中插入有害代码,然后重新分发受感染的应用程序。

最安全的方法是从Mac App Store查找更高版本的应用程序或寻找替代应用程序。

要覆盖您的安全设置并打开应用程序:

在Finder中,找到要打开的应用程序。

不要使用Launchpad来执行此操作。 Launchpad不允许您访问快捷菜单。

按住Control键并单击应用程序图标,然后从快捷菜单中选择“打开”。

单击打开。

该应用程序将保存为您的安全设置的例外,您可以通过双击它来打开它,就像任何已注册的应用程序一样。

注意:您还可以通过单击“安全和隐私”首选项的“常规”面板中的“打开任何方式”按钮,为被阻止的应用程序授予例外。尝试打开应用程序后,此按钮可用大约一小时。

要打开此窗格,请选择Apple菜单>系统偏好设置,单击安全和隐私,然后单击常规。

打开“常规”窗格。

要更改安全设置,请参阅保护Mac免受恶意软件侵害。


Foundry客户提出的另一个工作流程是在shell中运行以下命令:
sudo spctl --master-disable


这篇文章有帮助吗?
/

We're sorry to hear that!

Please tell us why.
16 人中有 6 人觉得有帮助

评论