症状
部分用户目前无法启动Nuke ,并收到以下错误信息:
EXCEPTION REPORT
User message is 'OpenCL Error: CL_INVALID_DEVICE (Device invalid or not associated with context)'.
Threw exception of type RIP::Compute::OpenCL::DeviceException
From Compute::Compute::OpenCL::OpenCLDevice.cpp:231 in 'RIP::Compute::OpenCL::Device::createDeviceInfo'
Decoration is...
[Error] = CL_INVALID_DEVICE (Device invalid or not associated with context)
UserMessage] = OpenCL Error: %%(Error)%% [UserMessage] = OpenCL Error: %%(Error)%%
或者:
EXCEPTION REPORT
User message is 'Unsupported OpenCL device'
Threw exception of type Foundry ::Base::Exception
From W:.conan\7c7cb3\1\Compute\src\OpenCL\ripOpenCLDevice.cpp:217 in 'RIP::Compute::OpenCL::Device::createDeviceInfo'
Decoration is...
[CLDeviceType] = 5
[UserMessage] = Unsupported OpenCL device
该问题似乎在Nuke 10.0v1 到 15.0v2 之间的所有测试过的Nuke版本中都会出现,但似乎只影响 Windows 11 用户。
原因
我们认为这与 Windows 11 更新或 GPU 驱动程序更新有关,但我们尚未能确认这是否是确切原因,如果是,也无法确定是哪个更新导致了这个问题。
我们已通过在 Windows 11 机器上安装 OpenCL™、OpenGL® 和 Vulkan® 兼容包,成功重现了该问题。因此,我们已针对此问题提交了错误报告,您可以通过以下链接查看该报告:
ID 564372 - Nuke因 OpenCL 错误在启动时崩溃
解决
从Nuke 14.1v4 和 15.0v4 版本开始,以下错误已被修复,该问题应该不再出现:
ID 564372 - Nuke因 OpenCL 错误在启动时崩溃
这些Nuke版本的下载链接可以在我们网站的以下页面找到:
对于Nuke 14.1v4 和Nuke 15.0v4 之前的版本, Nuke Microsoft Store 安装的 OpenCL™、OpenGL® 和 Vulkan® 兼容包可能会导致此问题。请检查您是否安装了此兼容包,如果已安装,请将其卸载。您可以通过在“开始”菜单中搜索“添加或删除程序”,然后在“应用”列表中找到 OpenCL™、OpenGL® 和 Vulkan® 兼容包并将其卸载来完成此操作。

注意:如果其他应用程序依赖于 OpenCL™、OpenGL® 和 Vulkan® 兼容包才能运行,那么这些应用程序可能会出现问题。
如果在移除兼容包或更新到Nuke 14.1v4 或 15.0v4 后仍然遇到此问题,请提交支持工单,并在工单标题中注明 OpenCL,并提供以下信息:
1) 请告知我们卸载 OpenCL™、OpenGL® 和 Vulkan® 兼容包没有帮助,或者您一开始就没有安装它。
2)您机器的完整系统规格。
有关如何生成包含此信息的报告的说明,请参见此处:
Q100520:获取硬件规格的操作系统报告,以便在Foundry支持调查期间发送
3) 由于此问题可能与同时拥有集成显卡和独立显卡有关,我们建议您禁用集成显卡并重启计算机。请告知我们重启后是否能够启动Nuke 。
有关如何禁用集成显卡的说明,请参阅此处:
Q100578:Intel 集成显卡驱动程序导致Foundry软件启动时崩溃
4)尝试在您的计算机上全新安装所有 GPU 驱动程序,并告诉我们这是否有帮助。
您可以使用显示驱动程序卸载程序(DDU) 卸载 GPU 驱动程序,然后从 GPU 制造商的网站下载最新的 GPU 驱动程序:
DDU:
https://www.guru3d.com/files-details/display-driver-uninstaller-download.html
Nvidia驱动程序:
https://www.nvidia.com/download/index.aspx
AMD驱动程序:
https://www.amd.com/en/support
注意:由于 DDU 是第三方解决方案,我们无法提供任何使用支持。
延伸阅读
有关如何提交支持工单的更多信息,请参阅我们的Q100064:如何提交支持工单文章。
我们很遗憾听到
请告诉我们