创建支持服务单
关注

Q100340:因缺乏OpenGL 2.0 GPU驱动 程序导致Nuke 11在启动时崩溃

问题状况

自Nuke 11发布以来,有多位用户在交互模式(GUI)中启动Nuke后直接崩溃, 或在出现小错误和GUI不一致后立即崩溃。这些问题从Nuke 11版才开始出现。但在之前的Nuke版本中(Nuke 10.5v7及更低版本)并不会出现。

此问题可能在以下情况中出现:

  1. 运行Nuke的计算机上未安装显卡(GPU)
  2. GPU驱动程序被禁用
  3. GPU硬件的显存没有达到512 MB以上,缺少OpenGL 2.0的驱动程序支持

 

问题原因

的最低系统需求已规定,为了运行软件,您需要安装有显卡,并且最少需 要512 MB的显存,且支持OpenGL 2.0的驱动程序。

在线帮助中的安装和授权部分也介绍了这一点:Windows系统Mac OSX系统 Linux系统

启动时崩溃或因GUI问题导致崩溃的原因在于运行Nuke的计算机:

  • 没有GPU
  • 未安装或禁用了GPU和/或驱动程序
  • GPU所运行的OpenGL版本没有达到所需的2.0框架
  • GPU的显存低于512MB
  • 在没有GPU或GPU不满足上述要求的机器上通过远程桌面会话启动Nuke
  • 上述各因素的任意组合

默认情况下,Nuke 11需要GPU才能正确运行所有图形界面进程,而且不再像 11.0v1版本之前那样使用CPU。

此问题由于Nuke 11的VFX Platform 2017 整合的需求而引出,该平台提供了一组 标准化的交叉兼容库。问题的具体原因是:由于Qt5的更新,现在需要OpenGL 2.0才能正常运行。

 

示例

以下是Nuke在启动时便崩溃的情况,在命令提示符中已显示出了与 “QOpenGLShaderProgram”相关的GPU错误。此问题的成因是该机器的 GPU使用了低于2.0版本的OpenGL驱动程序,因此无法加载运行Nuke 11所需
的信息。

 

2017-09-29.png

显示错误是我们在此问题中最常见的迭代,并已记录在了以下错误报告中: TP 311343 - Nuke 11 crashes without the minimum required GPU hardware which supports OpenGL 2.0

 

解决方案

如果您在启动Nuke 11时遇到崩溃,或在开始Nuke时碰上其它GPU相关的错误 以及/或者图形界面问题。且错误在Nuke 10(或更早版本)不会重演,请尝试 以下操作:

  • 确认您的显卡驱动程序已更新到最新版本
  • 确保您的GPU与OpenGL 2.0版本相兼容
  • 确保您的GPU具有至少512MB的显存


注意:如果机器除了系统显示所用的集成显卡之外,没有再安装满足最低 512MB显存,且支持OpenGL2.0版本驱动的显卡,则无法在交互模式(GUI)下运行Nuke 11。

 

扩展信息

如果已确认显卡符合最低系统要求,并安装有最新驱动程序,但仍然遇到问题 ,请发送客服工单,告诉我们您遇到的问题以及您截止目前已采取的故障排除 步骤。

有关如何发送支客服工单的更多信息,请参阅“运用支持门户”一文。
这篇文章有帮助吗?
/

We're sorry to hear that!

Please tell us why.
16 人中有 4 人觉得有帮助

评论