Q100641: 단일 머신에 중복된 플로팅 라이선스가 체크아웃되었습니다.

증상

플로팅 라이선스는 호스트 머신당 하나씩 공유되도록 설정되어 있습니다. 즉, 사용자는 서버에서 라이선스를 하나만 가져오면서 워크스테이션에서 여러 프로그램 인스턴스를 실행할 수 있습니다.

그러나 어떤 경우에는 하나의 사용자/호스트 컴퓨터에 여러 개의 플로팅 라이선스가 체크아웃되는 경우가 있을 수 있습니다. 다행히도 이런 일은 방지할 수 있습니다.

원인

RLM 서버는 기능 이름과 버전 번호(유지 관리 날짜)별로 라이선스를 그룹화합니다. 동일한 제품에 대해 동일한 유지 관리 날짜를 가진 라이선스가 여러 개 있는 경우, 서버에서 하나의 큰 풀로 분산됩니다.

라이선스 유지 관리 날짜는 라이선스 텍스트의 제품 이름 옆에 있는 날짜를 통해 확인할 수 있습니다. 예를 들어 다음 라이선스는 다음과 같습니다.

라이센스 foundry nuke _i 2022.0622 는 2022년 6월 22일에 유지 관리 날짜가 있는 Nuke 대화형 라이센스입니다.

실제로 이는 동일한 유지 관리 날짜를 가진 제품에 대한 여러 라이선스가 모두 동일한 풀에 배치된다는 것을 의미합니다.

동일한 유지 관리 날짜로 라이센스를 설치했습니다.

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결과 라이센스 풀

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하지만 유지 관리 날짜가 다른 라이선스(따라서 버전 번호도 다름)가 있는 경우 서버는 별도의 풀에서 해당 라이선스를 플로팅합니다.

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이로 인해 문제가 발생해서는 안 되지만 RLM 라이선싱과 관련하여 한 사용자에게 여러 라이선스가 체크아웃되는 문제가 발견되었습니다. 하지만 테스트 결과 이 문제는 두 번째 풀의 버전이 풀 1의 버전보다 낮은 경우에만 발생합니다.


라이센스 설치

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결과 라이센스 풀

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이론상으로는 사용자가 영구 라이선스보다 유지 관리 날짜가 짧은 추가 라이선스를 가지고 있는 경우 이런 일이 발생할 수 있습니다.

 

해결

가능하다면 기존 라이선스와 동일한 유지 관리 날짜를 지정하여 단기 라이선스를 생성함으로써 이를 방지할 수 있습니다.

서로 다른 유지 관리 날짜가 있는 라이선스가 이미 있는 경우, 서버에서 라이선스 파일을 수동으로 편집하여 유지 관리 날짜 순으로 라이선스를 정렬하면 중복 체크아웃을 방지할 수 있습니다. 이렇게 하면 더 높은 버전이 파일에서 나중에 나타납니다.

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추가적인 도움이 필요하신가요?

여전히 어려움을 겪고 있다면 지원 티켓을 생성하여 발생한 정확한 문제와 취한 문제 해결 단계를 알려주시기 바랍니다.

지원 요청을 여는 방법에 대한 자세한 내용은 다음 문서를 참조하세요. Q100064: 지원 티켓을 제기하는 방법

추가 읽기

Q100602: 플로팅 라이선스에 대한 자세한 정보를 찾을 수 있는 곳

Q100264: 머신을 라이센스 서버로 지정하는 방법

Q100211: RLM 서버에서 사용 가능한 라이센스를 확인하는 방법

Q100523: Foundry 라이선스는 내 컴퓨터의 어디에 설치되어 있나요?

Q100106: Nuke 라이선스는 어떻게 적용되나요?

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