증상
Windows에서 Nuke 12 버전을 실행하려고 할 때 명령 프롬프트에 다음 오류 메시지가 나타나면서 사용자가 충돌을 보고했습니다.
작업자 프로세스가 실패했습니다. Hiero 치명적인 오류가 발생했습니다. 이는 처리되지 않은 예외로 인해 발생했을 가능성이 높습니다.
이 문제가 있는 대부분의 기자는 Nuke 비상업용, 평가판 또는 교육용 라이센스를 사용합니다. 그러나 이는 Nuke 의 상업용 라이센스에 대해서도 보고되었습니다.
원인
" 작업자 프로세스 실패... " 오류 메시지는 일반적으로 프레임 서버가 기본 Nuke GUI 세션에 연결할 수 없는 프레임 서버 문제에서 발생합니다. 프레임 서버가 GUI 세션에 연결하는 것을 방해할 수 있는 여러 가지 요인이 있으며 주요 원인 중 하나는 QuickTime이 설치되어 있는 것 같습니다.
조사 결과에 따르면 이 문제에는 여러 가지 잠재적인 원인이 있는 것으로 보입니다.
a) PATH 환경 변수에 필수 QuickTime 디렉토리가 없거나 영어가 아닌 형식으로 설치된 QuickTime이 Nuke 실행에 영향을 미칠 수 있습니다.
b) 'Apple Application Support' 프로그램이 기기에 설치되어 있지 않습니다.
Nuke 12.0+ 버전은 QuickTime 종속성을 줄이기 위해 개발 변경을 거쳤으며, 이는 문제가 나타나기 시작하는 잠재적인 원인입니다. 테스트 결과 이 문제는 Nuke 13.0+ 릴리스에서 해결된 것으로 나타났습니다.
해결
다음은 문제를 직접 경험한 사용자의 동작을 방지한 몇 가지 해결 방법입니다.
QuickTime 제거:
QuickTime을 설치한 사용자의 경우 QuickTime을 제거하면 문제가 해결된 것 같습니다. Apple Application Support 프로그램을 다시 설치합니다.
QuickTime을 설치합니다:
이전에 QuickTime을 설치하지 않은 경우 권장 버전의 QuickTime 7.7.9를 설치하면 Nuke 올바르게 시작하는 데 도움이 되는 경우도 있습니다.
PATH 환경 변수를 확인합니다 .
QuickTime이 설치된 경우 PATH 환경 변수에 QuickTime 설치 경로가 포함되어 있는지 확인하십시오. QuickTime 경로의 기본값은 C:\Program Files (x86)\QuickTime\QTSystem\ 입니다.
QuickTime이 설치되었지만 비활성화되었습니다.
문제가 발생했지만 QuickTime을 계속 설치해야 하는 사용자의 경우 NUKE _QUICKTIME_ENABLE=0
환경 변수를 설정하십시오.
환경 변수를 설정하는 방법에 대한 지침은 Q100015: 환경 변수를 설정하는 방법 문서에서 찾을 수 있습니다 .
추가 도움말
위의 해결 방법을 시도한 후에도 Nuke 시작할 때 여전히 충돌이 발생하는 경우 지원 요청을 열고 발생한 정확한 문제와 수행한 문제 해결 단계를 알려주십시오.
지원 요청을 여는 방법에 대한 자세한 내용은 다음 문서를 참조하십시오. Q100064: 지원 티켓을 올리는 방법
우리는 문제로 불편을 끼쳐 드려 죄송합니다
이유를 알려주세요