증상
macOS 설치가 Nuke [버전]이 손상되어 열 수 없습니다."라는 오류와 함께 실패할 수 있습니다. Nuke를 휴지통으로 옮겨야 합니다. 이 문제는 macOS 사용자들이 보고했으며, 오류는 아래 이미지와 같습니다.

원인
Nuke 설치할 때 소프트웨어 실행 시 Nuke 손상되었습니다..." 라는 메시지를 표시하는 보안 기능과 충돌할 가능성이 있습니다. 추가 조사 결과, macOS의 Gatekeeper 보안 애플리케이션이 Nuke 에 속성을 추가하여 실행 시 Nuke가 열리지 않고 앞서 언급한 오류가 표시되는 것으로 보입니다.
해결
macOS에 Nuke 설치한 후 실행할 때 위의 오류 메시지가 나타나면 아래에 설명된 단계를 따르세요.
소프트웨어를 열려면 Mac 보안 설정을 일시적으로 무시하세요.
macOS에서는 애플리케이션이 공증되지 않았거나 신원이 확인되지 않은 개발자가 개발한 애플리케이션이기 때문에 설치 또는 실행에 실패할 수 있습니다. 이러한 실패한 애플리케이션은 Gatekeeper 보안 설정( Apple 메뉴 > 시스템 환경설정 > 개인 정보 보호 및 보안 > 보안 섹션) 에 표시됩니다. 아래와 같이, 애플리케이션을 열거나 설치할지 확인하려면 '어쨌든 열기' 버튼을 클릭하세요.
참고: Finder를 열라는 메시지가 표시되면 Finder에서 앱을 Command 키를 누른 채 클릭하고 메뉴에서 '열기'를 선택한 다음, 나타나는 대화 상자에서 '열기'를 클릭하세요 . 관리자 이름과 비밀번호를 입력하여 애플리케이션을 여세요.
이제 Nuke 보안 설정에서 예외로 저장되었으며, 다른 승인된 애플리케이션처럼 두 번 클릭하여 나중에 열 수 있습니다. 또는 터미널을 사용하여 Gatekeeper의 모든 보안 기능을 일시적으로 비활성화할 수 있습니다. 보안 소프트웨어를 비활성화하면 맬웨어와 같은 원치 않는 소프트웨어의 침입에 노출될 수 있다는 점에 유의하세요.
Gatekeeper 비활성화를 계속하려면 터미널에서 다음 명령을 실행하세요.
sudo spctl –master-disable
sudo spctl –master-enable
Nuke 시작하기 위해 특정 확장 속성을 비활성화하거나 제거하는 방법:
경고: 다음 정보는 확장 속성을 수정하면 의도치 않거나 예상치 못한 결과가 발생할 수 있으므로 권장되지 않습니다. 아래 단계를 수행하는 데 따르는 모든 책임은 사용자에게 있습니다.1. 관리자로서 터미널에서 다음 명령을 실행하여 애플리케이션의 확장된 속성을 확인하세요( Nuke 가 기본 위치에 설치된 경우):
sudo xattr /Applications/ Nuke 16.0v4/ Nuke 16.0v4.app
위 명령을 실행하면 다음과 비슷한 결과가 나옵니다.
com.apple.quarantine 이 있어야 하며, 이 속성은 애플리케이션 실행을 방해합니다. Nuke 애플리케이션에 이 줄이 있는 경우 다음 단계로 진행하여 제거하세요.2. 관리자 권한으로 터미널에서 다음 명령을 실행하여 격리 확장 속성을 제거합니다.
sudo xattr -d com.apple.quarantine /Applications/ Nuke 16.0v4/ Nuke 16.0v4.app
또는 애플리케이션의 모든 확장 속성을 제거하려면 다음 코드를 사용하세요.sudo xattr -cr /Applications/ Nuke 16.0v4/ Nuke 16.0v4.app참고: -c 플래그는 모든 속성을 제거하는 반면, -r 플래그 는 대상 .app 디렉터리 전체 내용에 재귀적으로 적용됩니다. 이러한 플래그에 대한 자세한 내용은 터미널에서 xattr -h 플래그를 사용하거나 아래 추가 자료 섹션의 내용을 참조하세요.
Gatekeeper가 할당한
com.apple.quarantine 확장 속성을 제거한 후에는 Nuke Nuke 되었다는 오류 없이 Nuke를 시작할 수 있어야 합니다. 추가 읽기
- macOS Gatekeeper 애플리케이션 에 대한 자세한 내용은 다음을 검토하세요.
- Gatekeeper 명령에 대한 자세한 내용을 알아보려면 이 링크를 검토하세요.
- 또한, 다음을 참조하세요. xattr 명령에 대한 자세한 정보 속성
추가 도움말
위의 단계를 수행한 후에도 Foundry 소프트웨어를 실행할 때 여전히 문제가 발생하는 경우 지원 요청을 열어 발생한 정확한 문제와 수행한 문제 해결 단계를 알려주시기 바랍니다.
지원 요청을 여는 방법에 대한 자세한 내용은 다음 문서를 참조하세요. Q100064: 지원 티켓을 제기하는 방법
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