Q100578: Intel 통합 그래픽 드라이버로 인해 Foundry 소프트웨어가 실행 시 충돌합니다.

증상

Foundry 제품 출시 중 충돌이 발생한다는 사용자 신고가 여러 건 접수되었습니다. 이 문제를 보고한 사용자 대부분은 Windows 10을 사용하고 있었으며, Windows 10에는 Intel 내장 그래픽 드라이버와 전용 그래픽 카드가 설치되어 있었습니다(예: Intel i7-7700 + Nvidia GTX 1050).

이 문서에서는 Foundry 소프트웨어를 성공적으로 실행하기 위해 통합 Intel 드라이버와 구성 요소를 다시 설치하거나 비활성화하여 특정 충돌이 발생하는 것을 방지하는 방법을 설명합니다.


원인

보고된 충돌은 Windows 10 컴퓨터에서 흔히 발견되었으며, 이 문제는 전용 GPU와 Intel 통합 그래픽 드라이버가 있는 컴퓨터와 관련된 것으로 보입니다. 생성된 충돌 보고서에 따르면 OpenCL 구성 요소(예: igdrcl64.dll 또는 igdrclneo64.dll)가 충돌의 원인인 것으로 나타났습니다. 위의 예시 구성 요소는 Foundry가 아닌 다른 소프트웨어에서도 유사한 문제가 보고되었습니다.

 

해결 방법

Foundry 애플리케이션 실행 시 충돌을 방지하려면 Intel 통합 그래픽 드라이버를 제거했다가 다시 설치하세요. 다음 단계를 수행하세요.

  1. Windows 시작 메뉴를 열고 앱 및 기능을 검색하세요.
  2. 목록에서 Intel Graphics Driver를 검색하세요. 이 드라이버는 Intel Graphics Media Accelerator Driver(Intel GMA Driver) 라고도 합니다.
  3. Intel 그래픽 드라이버를 마우스 오른쪽 버튼으로 클릭하고 제거를 선택합니다.

  4. Intel Installation Framework 창을 통해 안내되는 제거 안내를 따르세요. 프로세스를 완료하고 시스템을 다시 시작하세요.

  5. 시스템을 재시작한 후 영향을 받는 소프트웨어를 실행하세요. 충돌이 발생하지 않으면 최신 버전의 Intel 드라이버로 업데이트하세요. 아래 "추가 자료 " 섹션에 링크가 제공됩니다.

    그래도 충돌이 지속되면 아래 나열된 대체 솔루션 단계를 계속 진행하세요.

 

대안 솔루션:

영향을 받는 애플리케이션이 실행 시에도 여전히 충돌하는 경우, 시스템에 OpenCL 드라이버 구성 요소가 있을 수 있습니다. 해당 구성 요소를 비활성화하려면 다음을 수행하여 해당 구성 요소와 관련된 레지스트리 키를 수정하세요.

경고 : 레지스트리 값을 잘못 수정하면 치명적이거나 되돌릴 수 없는 오류가 발생할 수 있습니다. 이러한 값을 수정할 때는 각별히 주의해야 합니다.

  1. Windows 시작 메뉴를 열고 "regedit"를 검색한 다음 Enter를 누릅니다.
    - 또는 ( Windows 키 + R ) 단축키를 눌러 실행 메뉴를 열고 "regedit"를 입력한 다음 Enter 키를 누릅니다.
  2. HKEY_LOCAL_MACHINE\SOFTWARE\Khronos\OpenCL\Vendors
    로 이동합니다. HKEY_LOCAL_MACHINE\SOFTWARE\Khronos\OpenCL\Vendors

  1. Vendors 디렉터리에서 사용 가능한 각 OpenCL 구성 요소를 찾을 수 있습니다. 이름에 OpenCL이 있고 유형이 "REG_DWORD"인 항목을 두 번 클릭합니다. " 수정 "을 클릭하고 "값" 데이터 필드를 1로 설정한 후 "확인"을 선택합니다 .

참고 사항 : 하나의 값을 설정한 후에도 충돌 동작이 계속되면 "REG_DWORD" 유형이 나열된 각 항목에 대해 이 프로세스를 반복해야 할 수 있습니다.

  1. Regedit를 닫고 추가 변경 사항이 없도록 주의하세요.
  2. 이전에 영향을 받았던 소프트웨어를 실행합니다.

참고 사항: 위의 작업을 수행한 후에도 여전히 충돌이 발생하는 경우 추가 도움말 섹션으로 이동하세요.

  

추가 읽기

  

추가 도움말

위의 단계를 수행한 후에도 Foundry 소프트웨어를 실행할 때 여전히 충돌이 발생하는 경우 지원 요청을 열어 발생한 정확한 문제와 취한 문제 해결 단계를 알려주시기 바랍니다.

지원 요청을 여는 방법에 대한 자세한 내용은 다음 문서를 참조하세요.
Q100064: 지원 티켓을 제출하는 방법

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