Q100531: FLU를 통해 서버를 시작할 때 "서버 라이센스 호스트 이름 불일치"를 수정하는 방법

팔로우

증상

플로팅/서버 라이센스 파일에 유효하지 않은 호스트 이름이나 IP 주소가 포함되어 있거나 서버 시스템이 자체 호스트 이름을 확인하거나 연결할 수 없는 경우 라이센스 서버는 네트워크에서 라이센스를 시작하고 플로팅할 수 없습니다.

이런 일이 발생하면 FLU( Foundry Licensing Utility) 8.0은 라이센스 서버 페이지에 "서버 라이센스 호스트 이름 불일치"라는 오류 메시지를 표시합니다.

mceclip0.png

RLM 서버 로그에 다음 경고 메시지가 표시됩니다.

 06/19 11:50 (foundry) WARNING: No license file for this host (serverName)
06/19 11:50 (foundry)          The hostname in the license file(s)
06/19 11:50 (foundry)          may be incorrect

원인

이 문제의 두 가지 주요 원인은 라이센스 파일의 잘못된 호스트 이름과 시스템의 호스트 이름 문제입니다.

라이센스 파일의 호스트 이름이 잘못되었습니다.

부동/서버 라이센스의 첫 번째 라인인 HOST 라인에는 다음 형식으로 라이센스를 유동시킬 서버 시스템에 대한 정보가 포함됩니다.

HOST <server_name> <System_ID> <port number>
  • <server_name>은 로컬 호스트 이름, FQDN(정규화된 도메인 이름) 또는 서버 시스템의 IP 주소일 수 있습니다.
  • <System_ID>는 라이센스가 생성되는 SystemID입니다. 이는 머신에 대한 유효한 MAC 주소여야 하며 편집할 수 없습니다. 그렇지 않으면 라이센스가 유효하지 않습니다.
  • <포트 번호>는 기본 RLM 서버 프로세스가 실행될 포트입니다. Foundry 라이센스는 다른 RLM 서버와의 충돌을 피하기 위해 HOST 라인의 포트 4101로 발급됩니다.

FLU( Foundry Licensing Utility)가 서버/부동 라이센스를 설치하면 <server_name> 텍스트가 시스템의 호스트 이름으로 대체됩니다. 설치된 라이센스의 호스트 라인은 다음과 같습니다.

HOST redserver1 001122334455 4101

설치된 라이센스의 호스트 이름이 올바르지 않으면 RLM 서버를 실행할 수 없습니다. 여기에는 두 가지 주요 원인이 있습니다.

  • 라이센스가 수동으로 설치되었으며 <server_name> 필드가 서버 호스트 이름 또는 IP 주소로 업데이트되지 않은 경우
  • 컴퓨터가 네트워크 간에 이동하고 라이선스 설치 시 사용된 호스트 이름이 현재 네트워크에서 유효하지 않은 경우

호스트 이름 문제

서버를 실행하려면 머신이 라이센스 파일의 호스트 이름을 사용하여 머신과 통신할 수 있어야 합니다. 파일의 호스트 이름이 정확하지만 시스템이 해당 호스트 이름을 사용하여 자체적으로 연결할 수 없거나 시스템이 호스트 이름을 찾을 수 없는 경우 RLM 서버가 시작될 수 없습니다.

이는 컴퓨터나 네트워크에 DNS 문제가 있는 경우 발생할 수 있습니다. 모든 공유 설정이 꺼진 상태에서 macOS 컴퓨터를 라이센스 서버로 사용할 때 일반적인 문제가 될 수 있습니다.

해결

.local이 포함된 macOS 호스트 이름

이는 호스트 이름이 .local로 끝나고 공유 설정이 꺼져 있는 macOS 컴퓨터에서 흔히 발생하는 문제일 수 있습니다. 이 문제는 일반적으로 서버 시스템의 시스템 환경설정 내에서 "공유 서비스"를 켜면 해결될 수 있습니다.

  1. 시스템 환경설정 열기
  2. 공유를 클릭하고 " 파일 공유 " 확인란을 선택합니다.
  3. FLU를 다시 실행하고 License Server > Control Server로 이동합니다. 이제 서버를 다시 시작할 수 있습니다.

일반 지침

문제를 해결하려면 라이센스에 유효한 호스트 이름이 있는지, 머신이 자체적으로 통신할 수 있는지 확인해야 합니다.

1단계. 서버 시스템의 호스트 이름을 확인하세요.

터미널이나 명령 프롬프트에서 "hostname" 명령을 실행하여 현재 호스트 이름을 찾을 수 있습니다. 호스트 이름을 기록해 두십시오.

2단계. 라이센스 파일에서 호스트 이름을 확인하세요.

FLU에서 Licenses > View Installed 를 클릭하면 라이선스에 사용된 호스트 이름을 확인할 수 있습니다. 유효한 호스트 이름이 있는 라이선스는 유효한 라이선스 섹션에 나타나고, 잘못된 호스트 이름이 있는 라이선스는 잘못된 라이선스 섹션에 나타납니다.

mceclip3.png

라이센스를 클릭하면 라이센스가 시스템에 있는 위치와 유효하지 않은 이유(이 경우 "호스트 및/또는 공급업체 사양이 유효하지 않음")가 표시됩니다.

mceclip4.png

3단계. 필요한 경우 라이센스 파일 업데이트

파일의 호스트 이름이 시스템의 호스트 이름 또는 IP 주소와 다른 경우 서버를 실행하기 전에 업데이트해야 합니다.

  1. 라이센스 디렉토리에서 파일 브라우저 창을 열려면 "라이센스 설치 위치" 필드를 클릭하십시오.

  2. 텍스트 편집기로 라이센스 파일을 편집하고 올바른 호스트 이름을 갖도록 호스트 행을 업데이트하십시오.

    참고: 라이센스의 호스트 라인에 여전히 <server_name>이 있는 경우 파일을 다른 디렉터리로 이동하고 라이센스 > 설치 를 클릭한 다음 파일을 선택하고 설치를 클릭하여 FLU를 사용하여 설치할 수 있습니다.

  3. 라이센스 > 설치된 항목 보기 로 다시 이동하여 새로 고침 버튼을 클릭하세요. FLU는 라이센스가 유효한지 다시 확인합니다.

이제 라이센스가 유효하면 서버를 시작해 볼 수 있습니다. 라이센스 서버 > 제어 서버를 클릭한 다음 시작 또는 다시 시작 버튼이 나타나면 클릭합니다. 여전히 오류 메시지가 나타나면 컴퓨터에 호스트 이름이나 DNS 문제가 있는 것입니다.

4단계. 호스트 이름 문제 확인 및 수정

머신에서 명령 프롬프트나 터미널을 열고 다음 명령을 실행하여 머신이 자체 호스트 이름을 확인할 수 있는지 확인하세요.

ping serverName

여기서 serverName은 1단계의 컴퓨터 호스트 이름입니다. Ctrl+C를 사용하여 핑을 취소할 수 있습니다.

ping에서 100% 패킷 손실이 보고되거나 호스트 이름을 확인할 수 없는 경우 호스트 이름이나 DNS 문제로 인해 라이센스 서버가 시작되지 않는다는 의미입니다. 이 문제를 해결하려면 시스템 관리자에게 문의해야 할 수도 있습니다.

다음 단계

기기와 네트워크의 호스트 이름이나 DNS 문제를 해결할 수 없는 경우 시스템 관리자에게 문의하세요.

그래도 문제가 해결되지 않거나 서버를 시작할 수 없는 경우 지원 티켓을 제출하고 다음을 포함하십시오.

추가 읽기

라이센스에 대한 자세한 내용은Foundry 라이센스 온라인 도움말라이센스 서버 관리 섹션을 참조하십시오.

지원 포털에는 다음 문서에서 라이센스 서버를 설정하는 방법과 컴퓨터에서 라이센스를 보는 방법에 대한 정보가 있습니다.

    우리는 문제로 불편을 끼쳐 드려 죄송합니다

    이유를 알려주세요