Assertion failed: Address already in use (..\..\..\src\signaler.cpp:310)
사용자의 의도적인 조치 없이 Nuke 정상적으로 사용하는 동안 충돌이 발생합니다. 이 문제는 Windows 7 및 10 모두에서 내부적으로 재현되었습니다.
원인
이 충돌은 원래 Nuke 와 특정 Windows 빌드 간의 호환성 문제로 인해 발생한 것으로 보입니다. 내부 테스트에서는 Windows 10용 OS 빌드 17134.165인 것으로 보입니다.
그러나 이러한 업데이트를 설치한 후에도 일부 Windows 사용자에게 이 오류가 계속 발생한다는 보고가 접수되었습니다. Assertion failed
오류 메시지는 Nuke (및 기타 소프트웨어)가 포트 관리에 사용하는 타사 라이브러리 인 ZeroMQ에서 발생합니다.
- 때때로 보안 소프트웨어는 ZeroMQ가 포트를 의심스럽게 활용하는 방법을 확인하고 이러한 종류의 활동을 차단할 수 있습니다.
- ZMQ가 사용하려는 포트를 이미 사용하고 있는 다른 프로세스가 있을 수 있습니다.
이러한 충돌은 일반적으로 Nuke 의 프레임 서버에서 사용하는 포트에서 발생하며 다음 문서에서 이에 대한 자세한 정보를 찾을 수 있습니다.
Q100459: Nuke 프레임 서버에서 사용되는 포트
해결
내부적으로는 최신 Windows 업데이트를 설치하여 이 문제를 해결할 수 있었습니다. 이는 최신 업데이트를 설치한 후 더 이상 충돌이 발생하지 않는다는 사용자의 보고서를 통해 지원되었습니다. Windows 시스템의 문제를 해결하는 특정 업데이트는 KB345421, KB2267602 및 KB4340917 입니다.
Windows 업데이트를 수동으로 검색하고 설치하는 방법에 대한 자세한 내용은 Microsoft 웹사이트의 이 페이지를 참조하세요.
최신 Windows 업데이트를 이미 설치했는데도 이 오류가 계속 발생하는 경우 다음 테스트를 실행하여 문제가 계속 발생하는지 확인하는 것이 좋습니다.
- 프레임 서버를 비활성화한 상태에서 Nuke 시작합니다.
Q100378: Nuke , Nuke Studio 및 Hiero 용 프레임 서버를 비활성화하는 방법 - 가능하다면 방화벽과 Windows Defender를 포함하여 설치했을 수 있는 기타 보안 소프트웨어를 일시적으로 비활성화한 다음 평소처럼 Nuke 시작하십시오.
위 테스트 중 하나에서 오류가 발생하지 않으면 방화벽이나 보안 소프트웨어를 통해 필요한 포트를 허용해야 할 수도 있습니다. 또는 Nuke 의 프레임 서버에 필요한 포트를 사용하려는 다른 프로세스도 없는지 확인해야 할 수도 있습니다.
추가 읽기
위의 단계를 시도했지만 여전히 문제의 원인을 확인할 수 없는 경우 지원 티켓을 열고 사용 중인 Nuke 의 정확한 버전과 정확한 Windows 빌드, 그리고 지금까지 수행한 문제 해결 단계.
현재 Windows 빌드를 확인하려면 Windows 키 + R을 누르고 나타나는 대화 상자에 winver를 입력하세요. 이제 다음과 유사한 창이 표시됩니다.
지원 티켓을 여는 방법에 대한 자세한 내용은 Q100064: 지원 티켓을 올리는 방법 문서를 참조하세요.
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증상
여러 사용자가 Windows 7 및 10의 Nuke 에서 무작위 충돌이 발생하고 터미널에 다음과 유사한 오류 메시지가 표시된다고 보고했습니다.