Q100312: macOS에 'Contents Directory Missing' 메시지가 나타날 때 플러그인이나 키트를 설치하는 방법

팔로우

증상

macOS에서 Modo 에 플러그인이나 키트를 설치할 때 누락되거나 제한된 디렉토리로 인해 Modo 설치를 중단했음을 설명하는 '콘텐츠 디렉토리 누락' 메시지가 나타납니다.

error_message.png

이미지: '콘텐츠 디렉토리 누락' 메시지

원인

Modo 플러그인이나 키트의 콘텐츠를 설치하려면 /Library/Application Support/Luxology/ 디렉터리에 대한 전체 '읽기 및 쓰기' 권한이 필요합니다. 플러그인이나 키트를 설치하는 사용자에게 해당 폴더에 대한 읽기 및 쓰기 권한이 없으면 설치가 중단됩니다.

해결

먼저 /Library/Application Support/Luxology/Content/Assets 디렉토리가 있는지 확인하세요. 디렉토리가 없으면 Modo 제품 다운로드 페이지에서 컨텐츠 팩을 다운로드하여 설치할 수 있습니다. 이 팩을 설치한 후에는 이 디렉토리가 있어야 합니다.

이러한 콘텐츠 팩을 설치한 후에도 이 문제가 계속 발생하거나 이 문제를 해결하기 위해 이 디렉터리가 이미 존재하는 경우 관련 폴더에 대한 읽기 및 쓰기 권한을 설정해야 합니다. 이렇게 하려면 아래 지침을 따르십시오.

1. Finder 창에서 /Library/Application Support/Luxology/로 이동합니다.

2. Luxology 폴더를 마우스 오른쪽 버튼으로 클릭하고 "정보 가져오기"를 선택합니다.

3. 오른쪽 하단의 자물쇠를 클릭하고 비밀번호를 입력하여 설정을 편집하세요.

4. 공유 및 권한 섹션에서 사용자 옆에 "읽기 및 쓰기"라고 표시되어 있는지 확인하세요. 그렇지 않은 경우 변경하십시오.

5. 톱니바퀴 드롭다운을 클릭하고 '포함된 항목에 적용'을 선택하세요.

이를 통해 플러그인 및 키트 설치에 필요한 Luxology 폴더 내의 모든 디렉터리에 대한 쓰기 권한으로 Modo 시작할 수 있습니다.

이제 플러그인이나 키트를 성공적으로 설치할 수 있으며 Modo 플러그인이나 키트를 로드하기 위해 다시 시작하라는 메시지를 표시합니다.

추가 도움말

이 문서에 설명된 단계를 수행하는 데 문제가 발생하는 경우 지원 티켓을 열고 발생한 문제와 지금까지 수행한 문제 해결 단계를 알려주십시오. 이를 수행하는 방법에 대한 자세한 내용은 다음 문서를 참조하십시오. Q1000064: 지원 티켓을 올리는 방법.

    우리는 문제로 불편을 끼쳐 드려 죄송합니다

    이유를 알려주세요