症状
フローティングライセンスは、ホストマシンごとに1つずつ共有されるように設定されています。つまり、ユーザーはサーバーからライセンスを1つ取得するだけで、ワークステーション上で複数のプログラムインスタンスを実行できます。
ただし、状況によっては、複数のフローティング ライセンスが単一のユーザー/ホスト マシンにチェックアウトされてしまう可能性がありますが、幸いなことにこれを防ぐことができます。
原因
RLMサーバーは、機能名とバージョン番号(メンテナンス日)に基づいてライセンスをグループ化します。同じ製品のライセンスが複数あり、メンテナンス日が同じ場合は、それらのライセンスはサーバーから1つの大きなプールにフローティングされます。
ライセンスのメンテナンス日は、ライセンステキスト内の製品名の横に記載されている日付で確認できます。例えば、以下のライセンスが挙げられます。
LICENSE foundry nuke _i 2022.0622は、メンテナンス日が 2022 年 6 月 22 日のNukeインタラクティブ ライセンスです。
実際には、これは、同じメンテナンス日を持つ製品の複数のライセンスがすべて同じプールにフロートされることを意味します。
メンテナンス日が同じインストール済みライセンス
結果として得られるライセンスプール
ただし、メンテナンス日が異なるライセンス(したがってバージョン番号も異なる)がある場合、サーバーはそれらを別のプールからフロートします。
これによって問題が発生することはないはずですが、RLM ライセンスでは 1 人のユーザーに複数のライセンスがチェックアウトされる可能性があるという問題が発見されました。ただし、テストの結果、この問題は 2 番目のプールのバージョンがプール 1 のバージョンよりも低い場合にのみ発生します。
ライセンスのインストール
結果として得られるライセンスプール
理論的には、ユーザーが永久ライセンスよりもメンテナンス日が短い追加ライセンスを所有している場合に、これが発生する可能性があります。
解決
これを回避するには、可能な限り、既存のライセンスと同じメンテナンス日付で短期ライセンスを生成するようにします。
メンテナンス日が異なるライセンスが既にある場合は、サーバー上のライセンス ファイルを手動で編集してライセンスをメンテナンス日順に並べ、上位バージョンがファイル内の後ろの方に表示されるようにすることで、重複したチェックアウトを防ぐことができます。
さらにサポートが必要ですか?
引き続き問題が発生する場合は、サポート チケットを作成して、発生した問題の正確な内容と実行したトラブルシューティング手順をお知らせください。
サポートリクエストの提出方法の詳細については、こちらの記事をご覧ください: Q100064: サポートチケットの提出方法
さらに詳しく
Q100602: フローティングライセンスに関する詳細情報はどこで入手できますか
Q100264: マシンをライセンスサーバーにポイントする方法
Q100211: RLMサーバーから利用可能なライセンスを確認する方法
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