症状
macOSのインストールが、 Nuke [バージョン] が破損しているため開けません」というエラーで失敗することがあります。ゴミ箱に移動してください。この問題はmacOSユーザーから報告されており、エラーは以下の画像のような形で表示されます。

原因
Nukeをインストールすると、セキュリティ機能との競合が発生し、ソフトウェア起動時に「 Nukeが破損しています…」というメッセージが表示されます。さらに調査したところ、macOS の Gatekeeper セキュリティアプリケーションがNukeに属性を追加し、起動時に起動を阻止して前述のエラーを表示しているようです。
解決
macOS にインストールした後、 Nukeを起動したときに上記のエラー メッセージが表示された場合は、以下の手順に従ってください。
ソフトウェアを開くには、Mac のセキュリティ設定を一時的に無効にします。
macOSでは、アプリケーションが認証されていないか、開発元が不明なため、インストールや起動に失敗することがあります。この失敗したアプリケーションは、Gatekeeperのセキュリティ設定( Appleメニュー > システム環境設定 > プライバシーとセキュリティ > セキュリティ)に表示されます。 以下のように、アプリケーションを開いたりインストールしたりするかどうかを確認するには、 [とにかく開く]ボタンをクリックします。
注: Finderを開くように求められた場合は、FinderでアプリケーションをCommandキーを押しながらクリックし、メニューから「開く」を選択し、表示されるダイアログで「開く」をクリックします。管理者名とパスワードを入力してアプリケーションを起動してください。
Nukeセキュリティ設定の例外として保存され、今後は他の承認済みアプリケーションと同様にダブルクリックで開くことができます。または、ターミナルを使用して Gatekeeper のすべてのセキュリティ機能を一時的に無効にすることもできます。セキュリティソフトウェアを無効にすると、マルウェアなどの不要なソフトウェアが侵入する危険性があることにご注意ください。
Gatekeeper を無効にし続ける場合は、ターミナルで次のコマンドを実行してください。
sudo spctl –master-disable
sudo spctl –master-enable
Nukeを起動するために特定の拡張属性を無効化または削除する:
警告:拡張属性を変更すると、予期せぬ結果が生じる可能性があるため、以下の手順は推奨されません。以下の手順は自己責任で実行してください。1. 管理者として、ターミナルで次のコマンドを実行して、アプリケーションの拡張属性を表示します ( Nukeがデフォルトの場所にインストールされている場合)。
sudo xattr /Applications/ Nuke 16.0v4/ Nuke 16.0v4.app
上記のコマンドを実行すると、次のような結果が表示されます。
com.apple.quarantine存在する必要があり、アプリケーションの起動を妨げます。この行がNukeアプリケーションに存在する場合は、次の手順に進んで削除してください。2. 管理者としてターミナルで次のコマンドを実行し、検疫拡張属性を削除します。
sudo xattr -d com.apple.quarantine /Applications/ Nuke 16.0v4/ Nuke 16.0v4.app
あるいは、アプリケーションの拡張属性をすべて削除する場合は、次のコードを使用してください。sudo xattr -cr /Applications/ Nuke 16.0v4/ Nuke 16.0v4.app注: -cフラグはすべての属性を削除しますが、 -rフラグは対象の .app ディレクトリの内容全体に再帰的に適用します。これらのフラグの詳細については、ターミナルでxattr -hフラグを使用するか、以下の「参考資料」セクションを参照してください。
Gatekeeper によって割り当てられた
com.apple.quarantine拡張属性を削除すると、 Nuke Nukeが破損しています」というエラーなしで起動できるようになります。 さらに詳しく
- macOS Gatekeeperアプリケーションの詳細については、以下を参照してください。
-
ゲートキーパーコマンドの詳細については、 このリンクを参照してください。
-
さらに、以下もご覧ください xattrコマンドの詳細情報 属性
さらなる支援
上記の手順を実行した後でもFoundryソフトウェアの起動時に問題が引き続き発生する場合は、サポート リクエストを開いて、発生した問題の正確な内容と実行したトラブルシューティング手順をお知らせください。
サポートリクエストを開く方法の詳細については、次の記事を参照してください: Q100064: サポートチケットの発行方法
私たちはそれを聞いて申し訳ございません
理由をお聞かせください