症状
Foundry製品が起動中にクラッシュするというさまざまなユーザー報告があります。この問題を報告しているユーザーの大多数は Windows 10 を使用しており、マシンにインテル グラフィックス ドライバーと専用グラフィックス カードも統合されています。 (例: Intel i7-7700 + Nvidia GTX 1050 )
この記事では、統合されたインテル ドライバーとコンポーネントを再インストールまたは無効にして、 Foundryソフトウェアを正常に起動することで、特定のクラッシュの発生を防ぐ方法について説明します。
原因
報告されたクラッシュは Windows 10 マシンでよく発生しており、この問題は専用の GPU と Intel 統合グラフィックス ドライバーを搭載したマシンに関連しているようです。生成されたクラッシュ レポートは、OpenCL コンポーネント (例: igdrcl64.dll または igdrclneo64.dll) がクラッシュの原因であることを示しています。上記のコンポーネント例は、Foundry 以外の他のソフトウェアでも同様の問題があることが報告されています。
回避策
Foundryアプリケーションの起動時にクラッシュが発生するのを防ぐために、Intel 統合グラフィックス ドライバーを削除してから再インストールしてください。これを行うには、次の手順を実行してください。
- Windows のスタート メニューを開き、「アプリと機能」を検索します。
- リストから「Intel Graphics Driver」を検索します。このドライバーは「Intel Graphics Media Accelerator Driver (Intel GMA Driver)」と呼ばれることもありますのでご注意ください。
- 「Intel Graphics Driver」を右クリックし、「アンインストール」を選択します。
- Intel Installation Framework ウィンドウでアンインストールの指示に従います。プロセスを完了し、システムを再起動します。
- システムを再起動した後、影響を受けるソフトウェアを実行します。クラッシュが発生しない場合は、インテル ドライバーの最新バージョンに更新してください。リンクは、以下の「参考資料」セクションにあります。
それ以外の場合でもクラッシュが続く場合は、以下にリストされている代替解決策の手順に進んでください。
代替ソリューション:
影響を受けるアプリケーションが起動時に依然としてクラッシュする場合は、OpenCL ドライバー コンポーネントがシステム上に存在している可能性があります。コンポーネントを無効にするには、次の手順を実行して、コンポーネントに関連するレジストリ キーを変更します。
警告: レジストリ値を誤って変更すると、致命的なエラーや元に戻せないエラーが発生する可能性があります。これらの値を変更する場合は、細心の注意を払う必要があります。
- Windows のスタート メニューを開き、「regedit」を検索して Enter キーを押します。
- または、 [Windows キー + R]ホットキーを使用して [ファイル名を指定して実行] メニューを開き、「regedit」と入力して Enter キーを押します。 - 「 HKEY_LOCAL_MACHINE\SOFTWARE\Khronos\OpenCL\Vendors 」に移動します。
- 「Vendors」ディレクトリには、利用可能な各 OpenCL コンポーネントがあります。名前に OpenCL が含まれ、タイプが「REG_DWORD」の項目をダブルクリックします。 「変更」をクリックし、「値のデータ」フィールドを「1」に設定し、 「OK」を選択します。
注: 値を設定した後もクラッシュ動作が続く場合は、「REG_DWORD」タイプがリストされている項目ごとにこのプロセスを繰り返す必要がある場合があります。
- 追加の変更を加えないように Regedit を閉じます。
- 以前に影響を受けたソフトウェアを実行します。
注:上記を実行した後もクラッシュが発生する場合は、 「詳細ヘルプ」セクションに進んでください。
参考文献
- Intel 統合グラフィックス ドライバーの更新については、以下を参照してください。
- OpenCL とその機能の詳細については、こちらをご覧ください。
さらなるヘルプ
上記の手順を実行した後もFoundryソフトウェアの起動時にクラッシュが発生する場合は、サポート リクエストを開いて、発生した正確な問題と実行したトラブルシューティング手順をお知らせください。
サポート リクエストを開く方法の詳細については、次の記事を参照してください。
Q100064: サポート チケットを発行する方法
私たちはそれを聞いて申し訳ございません
理由をお聞かせください