症状
フローティング/サーバー ライセンス ファイルに無効なホスト名または IP アドレスが含まれている場合、またはサーバー マシンが自身のホスト名を解決できないか接続できない場合、ライセンス サーバーを起動してネットワーク上でフローティング ライセンスを実行することはできません。
この問題が発生すると、 Foundry Licensing Utility (FLU) 8.0のライセンス サーバーページに「サーバー ライセンスのホスト名が一致しません」というエラー メッセージが表示されます。
次の警告メッセージが RLM サーバー ログに表示されます。
06/19 11:50 (foundry) WARNING: No license file for this host (serverName)
06/19 11:50 (foundry) The hostname in the license file(s)
06/19 11:50 (foundry) may be incorrect
原因
この問題には主に 2 つの原因があります。ライセンス ファイル内のホスト名が間違っていることと、マシンのホスト名の問題です。
ライセンス ファイル内のホスト名が正しくありません
フローティング/サーバー ライセンスの最初の行である HOST 行には、ライセンスをフローティングするサーバー マシンに関する情報が次の形式で含まれています。
HOST <server_name> <System_ID> <port number>
- <server_name> には、サーバー マシンのローカル ホスト名、完全修飾ドメイン名 (FQDN)、または IP アドレスを指定できます。
- <System_ID> は、ライセンスが生成される SystemID です。これはマシンの有効な MAC アドレスである必要があり、編集できません。編集しないとライセンスが無効になります。
- <ポート番号> は、メイン RLM サーバー プロセスが実行されるポートです。 Foundryライセンスは、他の RLM サーバーとの競合を避けるために、HOST 行のポート 4101 を使用して発行されます。
Foundry Licensing Utility (FLU) がサーバー/フローティング ライセンスをインストールすると、<server_name> テキストがマシンのホスト名に置き換えられます。インストールされたライセンスのホスト行は次のようになります。
HOST redserver1 001122334455 4101
インストールされているライセンスのホスト名が間違っている場合、RLM サーバーは実行できません。これには主に次の 2 つの原因があります。
- ライセンスが手動でインストールされ、<server_name> フィールドがサーバーのホスト名または IP アドレスで更新されていない場合
- コンピュータがネットワーク間を移動し、ライセンスのインストール時に使用されたホスト名が現在のネットワークでは有効ではない場合
ホスト名の問題
サーバーを実行するには、マシンがライセンス ファイル内のホスト名を使用してそれ自体と通信できる必要があります。ファイル内のホスト名が正しいにもかかわらず、マシンがそのホスト名を使用して自身に接続できない場合、またはマシンがホスト名を見つけられない場合、RLM サーバーは起動できません。
これは、マシンまたはネットワークに DNS の問題がある場合に発生する可能性があります。これは、すべての共有設定をオフにして macOS マシンをライセンス サーバーとして使用する場合によく発生する問題です。
解決
.local を含む macOS ホスト名
これは、ホスト名が .local で終わり、共有設定がオフになっている macOS マシンでよく発生する問題である可能性があります。これは通常、サーバー マシンのシステム環境設定内の「共有サービス」のいずれかをオンにすることで修正できます。
- システム環境設定を開く
- 「共有」をクリックし、「ファイル共有」のチェックボックスをオンにします。
- FLU を再度起動し、 [ライセンス サーバー] > [コントロール サーバー] に移動します。これでサーバーを再起動できるようになります。
一般的なガイダンス
問題を解決するには、ライセンスに有効なホスト名があること、およびマシンがそれ自体と通信できることを確認する必要があります。
ステップ 1. サーバー マシンのホスト名を確認する
現在のホスト名を確認するには、ターミナルまたはコマンド プロンプトで「hostname」コマンドを実行します。ホスト名をメモしておきます。
ステップ 2. ライセンス ファイル内のホスト名を確認する
[Licenses] > [View Installed]をクリックすると、FLU からライセンスで使用されているホスト名を確認できます。有効なホスト名を持つライセンスは「有効なライセンス」セクションに表示され、無効なホスト名を持つライセンスは「無効なライセンス」セクションに表示されます。
ライセンスをクリックすると、ライセンスがマシン上のどこにあるか、ライセンスが無効である理由が表示されます。この場合は「ホストまたはベンダーの仕様が無効です」です。
ステップ 3. 必要に応じてライセンス ファイルを更新します。
ファイル内のホスト名がマシンのホスト名または IP アドレスと異なる場合は、サーバーを実行する前にファイルを更新する必要があります。
- 「ライセンスのインストール場所」フィールドをクリックして、ライセンス ディレクトリでファイル ブラウザ ウィンドウを開きます。
- テキスト エディタでライセンス ファイルを編集し、正しいホスト名になるようにホスト行を更新します。
メモ: ライセンスのホスト行に <server_name> がまだある場合は、ファイルを別のディレクトリに移動し、 [ライセンス] > [インストール]をクリックし、ファイルを選択して[インストール]をクリックすることで、FLU を使用してインストールできます。 - [ライセンス] > [インストール済みを表示]に再度移動し、更新ボタンをクリックします。 FLU はライセンスが有効かどうかを再度確認します。
ライセンスが有効になっている場合は、サーバーの起動を試行できます。 [ライセンス サーバー] > [コントロール サーバー]をクリックし、 [開始]ボタンまたは[再起動]ボタンが表示されたらクリックします。それでもエラー メッセージが表示される場合は、マシンにホスト名または DNS の問題があります。
ステップ 4. ホスト名の問題を確認して修正する
マシン上でコマンド プロンプトまたはターミナルを開き、次のコマンドを実行して、マシンが独自のホスト名を解決できるかどうかを確認します。
ping serverName
ここで、serverName はステップ 1 のマシンのホスト名に置き換えます。 Ctrl+C で ping をキャンセルできます。
ping が 100% のパケット損失を報告するか、ホスト名を解決できない場合は、ライセンス サーバーの起動を妨げるホスト名または DNS の問題があることを意味します。これを修正するには、システム管理者に相談する必要がある場合があります。
次のステップ
マシンおよびネットワーク上のホスト名または DNS の問題を解決できない場合は、システム管理者に問い合わせてください。
これでも問題が解決しない場合、またはサーバーを起動できない場合は、次の情報を含めてサポート チケットを発行してください。
- アプリケーションおよび/または FLU からのエラー/警告メッセージのスクリーンショット
- マシンのライセンス設定を確認するための、マシン上の FLU からの診断ファイル。 Q100105: ライセンス診断ファイルを生成する方法を参照してください。
参考文献
ライセンスの詳細については、Foundry Licensing オンライン ヘルプおよびライセンス サーバー管理セクションを参照してください。
サポート ポータルの次の記事には、ライセンス サーバーのセットアップ方法とマシン上のライセンスの表示方法に関する情報が記載されています。
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