Assertion failed: Address already in use (..\..\..\src\signaler.cpp:310)
このクラッシュは、ユーザーが意図的にアクションを起こすことなく、 Nukeを通常に使用しているときに発生します。この問題は、Windows 7 と 10 の両方で内部的に再現されています。
原因
このクラッシュは当初、 Nukeと Windows の特定のビルドとの間の互換性の問題によって引き起こされたようです。内部テストによると、Windows 10 の OS ビルド 17134.165 であるようです。
ただし、これらの更新プログラムをインストールした後でも、一部の Windows ユーザーでこのエラーが引き続き発生するという報告を受けています。 Assertion failed
エラー メッセージは、 Nuke (および他のソフトウェア) がポート管理に使用するサードパーティ ライブラリである ZeroMQ から発生します。
- 場合によっては、セキュリティ ソフトウェアが、ZeroMQ がポートをどのように利用しているかを不審なものとして認識し、この種のアクティビティをブロックする場合があります。
- ZMQ も使用しようとしているポートをすでに使用している別のプロセスがある可能性があります。
これらの競合は通常、 Nukeのフレーム サーバーが使用するポートで発生します。これに関する詳細については、次の記事を参照してください。
Q100459: Nuke Frame Server によって使用されるポート
解決
内部的には、最新の Windows 更新プログラムをインストールすることでこの問題を解決できました。これは、最新のアップデートをインストールした後にクラッシュが発生しなくなったというユーザーからの報告によって裏付けられています。 Windows マシンの問題を修正する特定の更新プログラムは次のとおりです: KB345421、KB2267602、およびKB4340917
Windows アップデートを手動でスキャンしてインストールする方法の詳細については、 Microsoft の Web サイトのこのページを参照してください。
最新の Windows 更新プログラムをすでにインストールしているのに、依然としてこのエラーが発生する場合は、次のテストを実行して、問題が引き続き発生するかどうかを確認することをお勧めします。
- フレーム サーバーを無効にしてNukeを起動します。
Q100378: Nuke 、 Nuke Studio 、およびHieroのフレーム サーバーを無効にする方法 - 可能であれば、ファイアウォールと、Windows Defender など、インストールされているその他のセキュリティ ソフトウェアを一時的に無効にしてから、通常どおりNukeを起動します。
上記のいずれのテストでもエラーが発生しない場合は、ファイアウォールまたはセキュリティ ソフトウェアを介して必要なポートを許可する必要がある可能性があります。あるいは、他のプロセスがNukeのフレーム サーバーに必要なポートを使用しようとしていないことを確認する必要がある場合があります。
参考文献
上記の手順を試しても問題の原因を特定できない場合は、サポート チケットを開いて、使用しているNukeの正確なバージョンと Windows の正確なビルド、およびこれまでに実行したトラブルシューティング手順。
現在の Windows ビルドを確認するには、Windows キー + R を押し、表示されるダイアログ ボックスに「winver」と入力します。次のようなウィンドウが表示されるはずです。
サポート チケットを開く方法の詳細については、 「Q100064: サポート チケットを発行する方法」の記事を参照してください。
私たちはそれを聞いて申し訳ございません
理由をお聞かせください
症状
複数のユーザーが、Windows 7 および 10 上のNukeで一見ランダムなクラッシュが発生し、ターミナルに次のようなエラー メッセージが表示されると報告しています。