症状
Mac OS X、Windows、Linux ではディスク権限の問題が発生し、ユーザーがライセンスをインストールできなくなることがあります。
Foundry Licensing Utility (FLU) 8.0 を使用してライセンスをインストールしようとすると、ライセンスをディスクに書き込むことができない場合、「インストールに失敗しました - ディスク書き込み許可エラー」を理由として無効なライセンス エラー メッセージが表示されます。
アプリケーションの [ライセンス] ダイアログからライセンスをインストールしようとすると、「ステータス [エラー]: ファイルを開けません。」 というエラー メッセージが表示されます。
原因
ノードロック、フローティング/サーバー、およびクライアント ライセンス ファイルのライセンス ディレクトリはマシン上のシステムの場所であり、マシンにログインしているすべてのユーザーがライセンスにアクセスできます。
- ウィンドウズ: 「C:\ProgramData\The Foundry \RLM\」および「C:\Program Files\The Foundry \RLM\」
- マックOS: /ライブラリ/アプリケーション サポート/TheFoundry/RLM/
- Linux: /usr/local/ foundry /RLM/
ディレクトリはシステムの場所にあるため、RLM ディレクトリの作成やその場所へのライセンス ファイルの書き込みには管理者権限が必要になる場合があります。 FLU またはアプリケーションを実行しているユーザーに管理者権限がない場合、ライセンスをインストールできない可能性があります。
解決
ノードロック ライセンスまたはクライアント ライセンスをインストールする場合は、 Foundry LicensingUtility 8.1.6 経由でインストールしてください。 FLU 8.1.6 は、https: //www.foundry.com/licensing/tools のリンクからダウンロードできます。
これにより、ライセンスがユーザーの場所にインストールされますが、権限は必要ありません。 FLU 8.1.6 は、ライセンスを次のパスにインストールします。
- ウィンドウズ: C:\Users\<ユーザー名>\FoundryLicensing\
- マックOS: /Users/<ユーザー名>/ Foundryライセンス/
- Linux: /home/<ユーザー名>/ Foundryライセンス/
フローティング ライセンスをインストールする場合は、ライセンスをインストールする前に、アプリケーションまたはFoundry Licensing Utility (FLU) を管理者として実行してみてください。管理者として起動する手順は次のとおりです。
管理者としてアプリケーションを起動する
- マックOS:
[アプリケーション] > [ユーティリティ] からターミナルを開き、sudo でプログラムを起動します。例:
sudo /アプリケーション/ Nuke 14.0v5/ Nuke 14.0v5.app/Contents/MacOS/ Nuke 14.0 - Linux:
sudo を使用してターミナルからアプリケーションを起動します。例:
sudo /usr/local/ Nuke 14.0v5/ Nuke 14.0 - Windows :
アプリケーションのショートカットを右クリックし、「管理者として実行」を選択します。
アプリケーションの起動に関する詳細については、learn.foundry.com をご覧ください。
管理者モードでの FLU の使用
- マックOS:
[アプリケーション] > [ユーティリティ] からターミナルを開き、次のコマンドを実行します。
cd /アプリケーション/ Foundry LicensingUtility.app/Contents/MacOS/
sudo Foundry LicensingUtility - Linux:
ターミナルで次のコマンドを実行します
cd /opt/ Foundryライセンスユーティリティ
sudo Foundry LicensingUtility - Windows :
Foundry Licensing Utility (FLU) を右クリックし、「管理者として実行」をクリックします。
次に、通常どおりライセンスをインストールします。
- Q100026: ノードロックライセンスをインストールする方法
- Q100027: フローティング/サーバー ライセンスをインストールする方法
- Q100264: マシンをライセンス サーバーにポイントする方法
Windows - ファイルの表示権限を確認する
それでも Windows で問題が発生する場合は、次のステップとして、ユーザーが ProgramData フォルダーを表示して、ライセンス ファイルの読み書きができるかどうかを確認します。
Windows エクスプローラーで、Windows の [フォルダーとプロパティ] - [表示] オプションの [隠しファイルとフォルダーを表示する] をオンにします。
参考文献
ライセンスの詳細については、を参照してください。 Foundryライセンスのオンライン ヘルプ
サポート ポータルには、さまざまなライセンス タイプとエラー メッセージのインストールに関する記事があります。
私たちはそれを聞いて申し訳ございません
理由をお聞かせください