Q100235:「ライセンス サーバーとの通信エラー」ライセンス エラー メッセージを解決する方法

フォローする

症状

フローティング ライセンス サーバーをセットアップし、コンピュータでライセンス サーバーを指定すると、プログラムは実行に失敗し、次のいずれかのエラー メッセージが表示されます。

ライセンスサーバーとの通信エラー (-17)

サーバーで接続が拒否されました (-111)
または
ライセンスサーバーとの通信エラー (-17)
ネットワークからの読み取りエラー (-105)

原因

このエラー メッセージは、サーバーが実行されていない場合、またはライセンス サーバーとクライアント マシン (ライセンスを要求しているコンピューター) の間にファイアウォールがある場合に表示されます。

ファイアウォールは、ライセンス要求が使用するポートを閉じるか、サーバー上の承認されたプログラムのみが他のコンピュータと通信できるようにすることにより、ライセンス要求をブロックしている可能性があります。

また、お客様のネットワーク セキュリティが RLM トラフィックを不審なものとして認識し、この通信をブロックした場合にもこのエラーが発生しました。

解決

この問題は、ライセンス サーバーとライセンス要求がファイアウォールを通過できるようにファイアウォール設定を変更することで解決できます。これは、サーバーに対して指定されたポートを開くか、 Foundry Licensing Tools (FLT) 内の RLM サーバー プログラムがサーバー経由で通信できるようにすることで実行できます。

この設定方法の詳細については、「Q100216: ファイアウォールを介してライセンス サーバーを使用する方法」を参照してください。

ネットワークが非常にロックダウンされている場合は、ISV が実行されるポートを設定し、ファイアウォールの通過も許可することをお勧めします。これを行う方法の詳細については、次の記事を参照してください: Q100374: RLM サーバーに専用の ISV ポートを使用させる方法

これでも問題が解決しない場合は、サポート チケットを開いて、サーバーとクライアント マシンの両方のFoundry License Utility (FLU) からの診断出力ファイルを添付してください。詳細については、次の記事を参照してください。

    私たちはそれを聞いて申し訳ございません

    理由をお聞かせください