Q100684: Windows 11で「OpenCLエラー: CL_INVALID_DEVICE」または「サポートされていないOpenCLデバイス」エラーが発生し、 Nuke 起動に失敗する

症状

現在、一部のユーザーはNukeを起動できず、次のエラーが表示されています。

EXCEPTION REPORT
 User message is 'OpenCL Error: CL_INVALID_DEVICE (Device invalid or not associated with context)'.
 Threw exception of type RIP::Compute::OpenCL::DeviceException
  From Compute::Compute::OpenCL::OpenCLDevice.cpp:231 in 'RIP::Compute::OpenCL::Device::createDeviceInfo'
 Decoration is...
   [Error] = CL_INVALID_DEVICE (Device invalid or not associated with context)
    UserMessage] = OpenCL Error: %%(Error)%% [UserMessage] = OpenCL Error: %%(Error)%%

または:

EXCEPTION REPORT
User message is 'Unsupported OpenCL device'
Threw exception of type Foundry ::Base::Exception
From W:.conan\7c7cb3\1\Compute\src\OpenCL\ripOpenCLDevice.cpp:217 in 'RIP::Compute::OpenCL::Device::createDeviceInfo'
Decoration is...
[CLDeviceType] = 5
[UserMessage] = Unsupported OpenCL device

この問題は、 Nuke 10.0v1 から 15.0v2 までのすべてのテスト済みNukeバージョンで発生するようですが、Windows 11 のユーザーにのみ影響するようです。

原因

これは Windows 11 の更新または GPU ドライバーの更新に関連していると考えられますが、これが正確な原因であることは確認できていません。また、原因である場合、どの更新がこの問題を引き起こしているのかについても確認できていません。

OpenCL™、OpenGL®、Vulkan®互換パックをWindows 11マシンにインストールすることで、社内で問題を再現することができました。この問題はバグとして記録されており、以下のリンクからレポートをご確認いただけます。

ID 564372 - OpenCLエラーによりNukeが起動時にクラッシュする

 

解決

Nuke 14.1v4 および 15.0v4 では、次のバグが修正されており、問題は発生しなくなりました。

ID 564372 - OpenCLエラーによりNukeが起動時にクラッシュする

これらのNukeリリースのダウンロード リンクは、当社の Web サイトの次のページにあります。

Nukeをダウンロード

Nuke 14.1v4およびNuke 15.0v4より前のNukeリリースでは、Microsoft StoreからOpenCL™、OpenGL®、およびVulkan®互換パックがインストールされていると、この問題が発生する可能性があります。インストールされているかどうかご確認ください。インストールされている場合はアンインストールしてください。アンインストールするには、スタートメニューで「プログラムの追加と削除」を検索し、アプリ一覧でOpenCL™、OpenGL®、およびVulkan®互換パックを検索してアンインストールしてください。

注意:他のアプリケーションが動作するために OpenCL™、OpenGL®、および Vulkan® 互換性パックを必要としている場合は、それらのアプリケーションで問題が発生する可能性があります。

互換パックを削除した後、またはNuke 14.1v4 または 15.0v4 にアップデートした後もこの問題が引き続き発生する場合は、チケットのタイトルに OpenCL と記載し、次の情報とともにサポート チケットを送信してください。

1) OpenCL™、OpenGL®、および Vulkan® 互換パックをアンインストールしても問題が解決しなかった、または最初からインストールされていなかったことをお知らせください。

2) マシンの完全なシステム仕様。
この情報を含むレポートを生成する手順については、以下を参照してください。
Q100520: Foundryサポート調査中に送信するハードウェア仕様のオペレーティングシステムレポートの取得

3) この問題は、内蔵GPUと専用GPUの両方を搭載していることにも関連している可能性がありますので、内蔵GPUを無効にしてマシンを再起動することをお勧めします。これによりNukeを起動できるかどうかお知らせください。
統合 GPU を無効にする方法については、次の場所を参照してください。
Q100578: Intel 統合グラフィック ドライバーにより、 Foundryソフトウェアが起動時にクラッシュする

4) マシン上のすべての GPU ドライバーをクリーン インストールしてみて、これが役立つかどうかをお知らせください。
ディスプレイ ドライバー アンインストーラー(DDU) を使用して GPU ドライバーをアンインストールし、GPU 製造元の Web サイトから最新の GPU ドライバーをダウンロードできます。

DDU:
https://www.guru3d.com/files-details/display-driver-uninstaller-download.html


Nvidia ドライバー:
https://www.nvidia.com/download/index.aspx


AMD ドライバー:
https://www.amd.com/en/support

注意: DDU はサードパーティ ソリューションであるため、その使用に関するサポートは提供できません。


さらに詳しく

サポート チケットを開く方法の詳細については、 「Q100064: サポート チケットの発行方法」の記事を参照してください。

    私たちはそれを聞いて申し訳ございません

    理由をお聞かせください