Q100278: ビューが空になったり、ジオメトリが消えた場合の対処方法

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症状

場合によっては、ビューが壊れているか空であるように見え、ナビゲーションや表示ジオメトリに応答していないように見える場合があります。この記事では、ビューがまだアクティブであることを確認する最良の方法、ビューポート カメラの制御を取り戻す方法、ジオメトリが確実に表示されるようにする方法について説明します。

この動作は、大規模なアーカイブやワークステーション間で受け渡されたアーカイブでよく発生します。その場合、以下のスクリーンショットにあるように、正射投影ビューはほとんど空のタブであるかのように表示されますが、他のビュー (主に UV ビュー) ではアセットが表示されたままであることがよくあります。

空のビューポート.png

原因

Mariのように複雑なソフトウェアでは、アセットの可視性、クリッピング プレーン、カメラがアセットから遠くに移動しているなど、一部またはすべてのビューが期待どおりに動作しない理由は数多く考えられます。ユーザーは、誤って間違ったショートカットを使用するなど、ビューが空になったり応答しなくなったりする動作を意図せずトリガーする可能性があり、考慮すべき潜在的なバグもあります。

最善のアプローチは、ビューに影響を与えるすべてのプロセスを実行し、それらが正しく設定されていることを確認することです。

解決

ビューがまだ機能することを確認する

最初のステップは、ビューにMariキャンバスがまだ含まれていることを確認することです。これをする:

  1. [表示] > [パレット] > [ライト]を選択して、[ライト]パレットを開きます。
  2. 環境ライトをオンにします。
  3. このパレットで、テクスチャ > イメージを選択し、環境ライトで使用する HDRI イメージの 1 つを選択します。

デフォルトでは、環境ライト オプションがオフになっているため、 Mariキャンバスが存在するかどうか、またナビゲーション ショートカットに応答しているかどうかがわかりにくくなっています。ただし、これをオンにすると、キャンバスがまだ存在し、回転できることがはるかに簡単にわかることがわかります。

以下はプロセスを示す画面記録です。

1EnableEnvironment.gif

ペイントバッファスケールのリセット

この段階でもビューポートが反応する場合は、ペイント バッファ をズームインまたはズームアウトしすぎて、誤ってジオメトリを見失った可能性があります。これは高解像度プロジェクトで作業しているときによく発生するため、ジオメトリが失われた場合はペイント バッファ スケールをリセットしてみることが重要です。

これを行うには、次の画面記録に示すように、 [ツール] ツールバー[ペイント バッファ ツール]グループから[ズームペイント バッファ] 虫眼鏡ツールを選択し、[リセット]ボタンを選択します。

3ResetPaintBuffer.gif

アセットのフレーミングとカメラのリセット

カメラの移動中にアセットを見失ってしまう可能性もあります。

ビューの中心をアセットに再設定するには、 [カメラ] > [すべて表示]を選択してください。

その後、アセットがまだ表示されない場合は、 [カメラ] > [カメラのリセット]も試行する必要があります。これにより、キャンバス ツールバーNearFar 、およびFoV設定がリセットされ、予期せずビューに影響を与える可能性があります。たとえば、ニアクリッピング プレーンの設定が高すぎる場合、ユーザーはシーンを非表示にすることができます。

Fig1_ResetCamera.png

カメラのロックを解除する

ナビゲーション ツールバーを使用すると、完全にロックされるまで、さまざまな方法でカメラの動きを制限できます。ナビゲーション ツールが編集されると、そのシンボルがオレンジ色になり、ユーザーはアセットを見つけるためにナビゲートできなくなる場合があります。

カメラのロックを完全に解除するには、ユーザーは左端のボタン「ナビゲーション設定をデフォルトにリセット」を押す必要があります。

アセットの可視性

Mariは、現在の選択モードに応じて 3 つの「表示モード」があります。誤って使用すると、ユーザーは自分のアセットを表示することが不可能であるという印象を受ける可能性があります。

たとえば、ユーザーがFace Modeでオブジェクト全体を選択し、その後[Hide Selected]を選択して非表示にした場合、オブジェクトパレットからオブジェクトを表示することはできません。これは、オブジェクトは技術的にはまだ表示されていますが、その面は表示されていないためです。

すべての面、パッチ、オブジェクトを表示するには、現在の選択モードとは関係なく、 [選択] > [すべて表示]をクリックする必要があります。

新しいオブジェクトを追加してビューをリセットする

数人のユーザーから、上記のトラブルシューティング オプションがどれも機能しない場合、シーンに大規模な 3D モデルを追加することでビューを強制的に完全にリロードできると報告されています。

新しいオブジェクトをシーンに追加するには、ユーザーはオブジェクトパレットを選択し、 [オブジェクトの追加]ボタンをクリックします。

追加する 3D モデルは各軸で 30cm より大きくなければなりません。これはサンプルプロジェクトのサイズの約 2 倍に相当します。サンプル プロジェクトは、[ヘルプ] > [サンプル プロジェクトの作成]を選択して参照目的で作成できます。

ナビゲーションの設定

ナビゲーションが予期しない動作をしている場合、ユーザーは[編集] > [環境設定] > [ナビゲーション]を選択して、すべてのナビゲーション設定をデフォルトにリセットしたり、コントロール タイプを変更したりすることもできます。これにより、ナビゲーション関連のショートカットの変更などの追加の効果が得られます。

シェーダーの問題

また、ビューをレンダリングするシェーダーが突然アセットを見つけられなくなり、そのアセットがレンダー内に存在しなくなる可能性もあります。したがって、上記の提案によって問題が解決しない場合は、 [ツール] > [シェーダー コンソール] > [すべて] / [シェーダーの再ロード]を選択する価値があります。どちらもシェーダーをリロードするため、アセットを再度見つけて表示するのに役立ちます。


さらなるヘルプ

それでも問題が解決しない場合は、サポート チケットを作成し、この記事で要求されている情報を提供してください。

Q100090: Mariの問題を報告する

サポート リクエストを開く方法の詳細については、次の記事を参照してください。

Q100064: サポート チケットを発行する方法

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