एक टिकट बनाएं
अनुसरण करें

Q100234: Nuke विभिन्न संस्करणों के बीच प्लग-इन संगतता

सारांश

Nuke संस्करणों के बीच NDK प्लग-इन संगतता के बारे में बताता है और जब NDK प्लग-इन को पुन: संकलित करने की आवश्यकता होगी।

अधिक जानकारी


एनडीके सी ++ एपीआई का उपयोग करके संकलित कोई भी Nuke Nuke की एक ही शाखा के लिए सभी वी-रिलीज़ के साथ संगत होगा। Nuke 12.1v1 के लिए प्लग-इन संकलित किया है तो यह 12.1v1 से 12.1v4 के साथ काम करेगा लेकिन यह Nuke 12.0 रिलीज़ या Nuke 12.2 रिलीज़ के साथ काम नहीं करेगा क्योंकि शाखा संख्या बदल गई है।

हालांकि रिलीज में 'न्यूक 12' नाम है, लेकिन हुड के तहत पर्याप्त बदलाव हैं कि Nuke के एनडीके प्लग-इन एपीआई के संदर्भ में यह 12.0.0.1 की तुलना में एक नया प्रमुख संस्करण है। एक ही तरीका है कि के लिए प्लग-इन में Nuke 12.0 के लिए फिर कंपाइल की जरूरत Nuke 12.1 विज्ञप्ति, के लिए अपनी सी ++ प्लग इन Nuke 12.2 के खिलाफ फिर कंपाइल करने की आवश्यकता होगी Nuke 12.2v1 NDK में काम करने के लिए उनके लिए आदेश में Nuke 12.2v1।
Ocula और Cara दोनों प्लगइन्स पर भी लागू होता है Nuke रिलीज़ संस्करण के विरुद्ध भी बनाए गए हैं।
Nuke की विभिन्न शाखाओं के साथ Cara VR संगतता के बारे में अधिक बताता है: Q100233: Nuke की विभिन्न शाखाओं के बीच CaraVR

क्या यह लेख उपयोगी था?

हम चाहते हैं कि खेद व्यक्त करते हैं

कृपया हमें बताएँ कि
2 में से 2 के लिए उपयोगी रहा