Q100579: Nuke fails to launch on macOS with a "Nuke is damaged..." error

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SYMPTOMS

The macOS installation can sometimes fail with the error “Nuke [version] is damaged and can’t be opened. You should move it to the trash.” This issue has been reported by macOS users on 10.14 Mojave through macOS 14 Sonoma, and can be seen as the image below: 

     


CAUSE

When installing Nuke, there is a potential conflict with security features that invoke the “Nuke is damaged...” message when launching the software. From further investigations, it looks like macOS’s Gatekeeper security application appends an attribute to Nuke, suspending it from opening at launch and displaying the aforementioned error. 

 

RESOLUTION

If you’ve received the above error message when launching Nuke after installation on macOS, please follow the steps outlined below.

Temporarily override your Mac security settings to open the software: 

In macOS 10.14 Mojave and 10.15 Catalina, an application can fail to install or launch because it hasn’t been notarized, or is from an unidentified developer. This failed application will appear in the Gatekeeper security settings: Apple Menu > System Preferences > Security & Privacy > General tab. Click the Open Anyway button to confirm wanting to open or install the application, as shown below:


The warning prompt may reappear, where you can then click Open.

NOTE: If you're prompted to open Finder, cmd-click the app in Finder, choose Open from the menu, and then click Open in the dialog that appears. Enter your administrator name and password to open the application.

Nuke should now be saved as an exception in your security settings, and you can open it in future instances by double-clicking it, just as you can any authorized application..

Alternatively, you can use Terminal to temporarily disable all the security features of Gatekeeper. Please keep in mind that disabling the security software will leave your machine open for intrusion by unwanted software, such as malware.

If you’d like to continue in disabling Gatekeeper, please run the following command in Terminal:
sudo spctl –master-disable

To re-enable Gatekeeper at any time, use this command:
sudo spctl –master-enable​

However, if you are still experiencing issues with launching the Nuke software after performing either of the above steps in disabling Gatekeeper, please proceed to the next step for removing the extended attributes.


Disabling or removing specific extended attributes to launch Nuke:
 

WARNING: The following information is not a recommended process because modifying extended attributes may have unintended or unforeseen consequences. Performing the steps below is at your own risk. 

1. As an Administrator, please run the following command in Terminal to view any extended attributes of the application (with Nuke installed to the default location):
sudo xattr  /Applications/Nuke15.1v2/Nuke15.1v2.app

Running the above command should give results similar to the following (where 13.1v1 is an older version the issue occurs with):


NOTE: The extended attribute com.apple.quarantine should be present for Nuke, and will prevent the application from launching. If this line is present for the Nuke application, please proceed to the next step to remove it.

2. As an Administrator, run the following command in Terminal to remove the quarantine extended attribute:
sudo xattr -d com.apple.quarantine /Applications/Nuke15.1v2/Nuke15.1v2.app

     

Alternatively, if you’d like to remove all extended attributes of the application, please use the following code:
sudo xattr -cr /Applications/Nuke15.1v2/Nuke15.1v2.app


NOTE: The -c flag removes all attributes, whereas -r applies recursively for the entire targeted .app directory contents. More information on these flags can be found with the xattr -h  flag in Terminal, or by viewing content in the Further Reading section below.

After removing the com.apple.quarantine extended attribute that was assigned by Gatekeeper, Nuke should now be able to launch without the “Nuke is damaged” error.

 

FURTHER READING 


FURTHER HELP
 

If you are still experiencing issues when launching Foundry software after performing the steps above, please open a Support request and let us know the exact issue encountered and the troubleshooting steps that have been taken.

For more information on how to open a Support request, please refer to this article: Q100064: How to raise a support ticket

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