SYMPTOMS
There have been various user reports about Foundry products crashing during launch. The majority of users reporting this issue were using Windows 10, which also have integrated Intel Graphics Drivers and dedicated graphics cards in their machines. (e.g Intel i7-7700 + Nvidia GTX 1050)
This article describes how to hopefully prevent specific crashes from happening by re-installing or disabling the integrated Intel Drivers and components to successfully launch Foundry software.
CAUSE
The reported crashes have been commonly found on Windows 10 machines, and the issue appears to be related to machines having a dedicated GPU and Intel integrated graphics drivers. The generated crash reports indicate that OpenCL components (e.g. igdrcl64.dll or igdrclneo64.dll) are causing the crashes to occur. The above example components have also been reported in other non-Foundry software having similar problems.
WORKAROUND
To help prevent any crashes from occurring when launching the Foundry applications, please remove the Intel integrated graphics drivers and then reinstall them. Please perform the following steps to accomplish this:
- Open the Windows Start Menu and search for “Apps & Features”.
- Search for “Intel Graphics Driver” in the list. Please note that the driver can also be called “Intel Graphics Media Accelerator Driver (Intel GMA Driver).”
- Right-click the “Intel Graphics Driver” and select “Uninstall”.
- Follow the uninstall prompts via the Intel Installation Framework window. Complete the process and allow the system to restart.
- After restarting the system, run the affected software. If no crashes occur, please update to the latest version of the Intel Drivers - a link is provided in the Further Reading section below.
Otherwise if crashing persists, please continue to the Alternative Solution steps listed below.
ALTERNATIVE SOLUTION:
If the affected application is still crashing on launch, OpenCL driver components may be present on the system. To disable the component, modify the registry keys relating to the component by performing the following:
WARNING: Incorrectly modifying registry values could cause fatal and/or irreversible errors. Extreme caution should be taken when modifying these values.
- Open the Windows Start Menu and search for “regedit”, then press Enter.
- Alternatively, open the Run menu with the [Windows Key + R] hotkey and type “regedit”, then press Enter. - Navigate to “HKEY_LOCAL_MACHINE\SOFTWARE\Khronos\OpenCL\Vendors”
- In the “Vendors” directory, you will find each of the available OpenCL components. Double-click the item with OpenCL in it’s name with the “REG_DWORD” Type. Click Modify and set the “Value data” field to “1”, then select OK.
NOTE: If the crashing behavior continues after setting the values for one, it may be necessary to repeat this process for each item with the “REG_DWORD” Type listed.
- Close Regedit, ensuring not to make any additional changes.
- Run the previously affected software.
NOTE: If you are still encountering a crash after performing the above, please continue to the Further Help section.
FURTHER READING
- Please view the following for updating the Intel integrated graphics drivers.
- Please view more information on OpenCL and it’s capabilities.
FURTHER HELP
If you are still experiencing crashes when launching Foundry software after performing the steps above, please open a Support request and let us know the exact issue encountered and the troubleshooting steps that have been taken.
For more information on how to open a Support request, please refer to this article:
Q100064: How to raise a support ticket
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