Q100575: How to resolve the “Failed to load studio-##.#.#.dll” error when launching Nuke on Windows Server

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SYMPTOMS

When trying to launch Nuke in Windows Server 20xx, you encounter the failed to load studio-##.#.#.dll error in the Command Prompt window, like:


CAUSE

The cause of the issue is related to a file installed within the Nuke directory, called studio-##.#.#.dll. This file is missing one of its dependent dll files that is required to function correctly, wlanapi.dll, which is part of the “WLAN AutoConfig service” used by Windows to control connecting to and detecting Wireless Networks.

In some cases where a virtual machine is being used, Nuke can fail to initailize after installing the wlanapi.dll.


RESOLUTION

You can resolve this issue by installing the “Wireless LAN Service” feature on your Windows Server operating system. This can be done through the “Server Manager”, a tool that is installed by default on Windows Server to help manage different aspects of your server.

To install this feature, please use the following steps:

1) Open the “Start Menu, Type  “Server Manager” and hit enter

2) Click “Add roles and features”

3) The “Before you begin” page should appear, click “Next” to continue

4) Select “Role-based or feature-based installation” and click “Next”

5) In “Server Selection”, select the server you wish to install the feature on and click “Next”

6) Change nothing in the “Server roles” area and click “Next”

7) In the “Features area”, scroll down and select the “Wireless LAN Service” and click “Next”

8) Under the “Confirmation area”, check the “Restart the destination server automatically if required” and then click the “Install” button.

After restarting the server, the “Wireless LAN Service” should be installed and Nuke should open as normal.

NOTE: If using a virtual machine (VM), Nuke can sometimes still fail to initialize, where it's been discovered that changing the CPU settings of the VM from KVM to host, Nuke then started without any errors.

 

FURTHER READING

If you are still seeing any issues after performing the steps outlined in this article, then please open a Support ticket and let us know the issue you are encountering and the troubleshooting steps you have taken so far.

For more information on how to open a Support ticket, please refer to the Q100064: How to raise a support ticket article.

You can find additional information on some extra troubleshooting steps that may be helpful with the issue you're experiencing in the following article:

Q100074: Nuke/NukeX/NukeStudio User Troubleshooting Guide

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