SYMPTOMS
It has been discovered that Katana, Mari, Modo and Nuke will sometimes fail to launch with a machine using an Intel 10th Gen (Ice Lake) CPUs or newer (11th Gen (Rocket Lake), 12th Gen (Alder Lake), 13th Gen (Raptor Lake) and later.
This issue only affects the Windows operating systems.
Nuke Indie, Nuke Non-Commercial and Mari Non-Commercial users have also reported that this issue may cause the Licencing dialog to crash while authorizing their device. After entering your details, and pressing Authorise Device:
A progress bar is then displayed, at which point, the dialog may close. This will result in the licence not being updated.
CAUSE
There is a bug in the version of OpenSSL that specific versions of the software ships with (1.0.2.g), where Intel 10th Gen (Ice Lake) CPUs or newer, crash due to an sha1 asm routine that incorrectly uses a rax register. More information on this can be found in the FURTHER READING section below.
WORKAROUND
As a workaround, you can set the following environment variable to correct the issue:
OPENSSL_ia32cap=~0x200000200000000
You can do this by accessing Control Panel > System > Advanced System Settings > Environment Variables… It’s possible that you may have to restart the machine after adding the environment variable for it to take effect.
The variable disables bits 33 and 54, and from the OpenSSL documentation, shouldn’t cause any security issues as it's just disabling processor capabilities. The documentation for the variable can be found in the FURTHER READING section below.
RESOLUTION
The issue should be fixed in OpenSSL 1.0.2i and newer. More information on this can be found in the FURTHER READING section below.
NUKE
An internal feature request had been logged for updating Nuke's version of OpenSSL, which can be referenced as:
ID 424014 - Upgrade Nuke's version of OpenSSL to 1.0.2i or newer
With the update to Nuke's version of OpenSSL to 1.0.2u, this issue should no longer occur in Nuke 13.0v8, 13.1v4 and 13.2v1, and later.
However, the issue will still be present in Nuke versions released prior to Nuke 13.0v8, 13.1v4 and 13.2v1 and you may need to use the workaround above.
MARI
Mari versions built against OpenSSL 1.0.2g could experience issues with the 10th/11th/12th Gen Intel CPUs.
NOTE: Most Mari users are reporting issues with 11th generation processors, rather than 10th.
An internal feature request was logged to upgrade the OpenSSL version under: ID 483084 - Upgrade Mari's version of OpenSSL to 1.0.2i or later
The OpenSSL version was upgraded to 1.0.2u starting with Mari 4.7v7, 4.8v2 and 5.0v2, and to 1.1.1m in Mari 6.0v1 and later.
KATANA
In Katana, we also have a bug logged for the crashing behaviour which was reported for the Rocket Lake 11th gen Intel CPU. You may reference this bug ID as:
ID 475083 - Katana crashes on launch on systems with Intel 11th gen CPUs
This bug was addressed in Katana 4.5v1 and later and should not experience this behaviour. Katana versions 4.5v1 and later are using OpenSSL 1.0.2u.
MODO
In Modo, there is also a confirmed issue where the Licensing UI does not appear as expected in Modo 15 when using these newer Gen Intel processors, and this was fixed in Modo 16.0v3 and later.
For more information on this specific problem please see the following knowledge base article:
Q100631: Licensing UI not appearing in Modo 15 with a 10th (Ice Lake), 11th (Rocket Lake) or 12th (Alder Lake) Generation Intel CPU
FURTHER READING
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Please view the following link for more information on the OpenSSL documentation.
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You can also view additional information about the Intel OpenSSL* SHA Crash Bug here.
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View more information on our Knowledge Base article: Q100015 - How To Set Environment Variables.
FURTHER HELP
If you are still having trouble launching Katana, Mari, Modo or Nuke after setting the OpenSSL environment variable while using a newer generation Intel CPU, please open a Support request to let us know the exact issue encountered and the troubleshooting steps that have been taken.
For more information on how to open a Support request, please refer to this article:
Q100064: How to raise a support ticket
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